Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

communicating with board

Status
Not open for further replies.

vinay shabad

Junior Member level 3
Joined
Dec 13, 2010
Messages
30
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,769
hii i am very new to microcontroller programming i am presently working on PIC24F16KA102 with MPlab and C30 compiler.I wrote this code but this code is building successfully but when i connect to hardware its not communicating with board

#include "p24F16KA102.h"

int main(void)
{
TRISBbits.TRISB3 = 0;
LATBbits.LATB3 = 1;

while(1) {}

}


its showing error as


The target device is not ready for debugging.
Please check your configuration bit settings and program
the device before proceeding.



please can someone help me to get rid of this problem thankyou in advance.
 

e shade

Member level 3
Joined
Dec 31, 2010
Messages
59
Helped
7
Reputation
14
Reaction score
6
Trophy points
1,298
Activity points
1,581
if you are trying to communicate through UART, what is the baud rate you set.Have you changed and tried.
 

horace1

Advanced Member level 5
Joined
Nov 18, 2008
Messages
2,123
Helped
596
Reputation
1,188
Reaction score
573
Trophy points
1,393
Location
Norwich, UK
Activity points
13,071
using MPLAB if you click on Programmer then Select Programmer the PicKit 3 what does it say?
e.g. don't have a PicKit 3 here but my ICD3 talking to a PIC24FJ64GB002 says
Code:
MPLAB ICD 3 detected
Connecting to MPLAB ICD 3...
Firmware Suite Version...... 01.26.33
Firmware type......................dsPIC33F/24F/24H
MPLAB ICD 3 Connected.
Target Detected
Device ID Revision = 00000002
can you do blank check, erase, program, etc.
 

bigdogguru

Administrator
Joined
Mar 12, 2010
Messages
9,831
Helped
2,348
Reputation
4,690
Reaction score
2,273
Trophy points
1,413
Location
Southwest, USA
Activity points
62,490
Under the top menu:

Project -> Build Configuration -> Debug

Make sure the Build configuration is set to Debug not Release.

Also make sure the PICkit 3 is selected as the Debugger Tool:

Top Menu: Debugger -> Select Tool -> PICkit 3

You can program the device for debugging, but you can't debug with the programmer!

Hope this helps.

Also, make sure you have the PIC24F16KA102 selected under:

Configure -> Select Device..-> PIC24F16KA102

And your Configuration Bits are set properly for the device and debugging, under Configure Menu.
 
Last edited:

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top