Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Characteristic Impedance of a CPS in Momentum

Status
Not open for further replies.

PhillipWalters

Newbie level 1
Joined
Sep 28, 2009
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,290
Hi Everyone,

I'm currently trying to use Momentum to simulate a strip using a custom substrate(4 substrate layers + 2 metal strip layers). After defining my substrate dimensions and material properties, I've put a port on each end(type single) and am running an S-Parameters simulation to try and plot the characteristic impedance of the line as a function of frequency. However, after running the simulation, I just get a flat 50 Ohms, which I'm fairly certain is dead wrong.

Can anyone possibly give me a hint as to what I'm doing wrong? I've looked all over the web and can't find anything on what I'm trying to do, nor have I been able to find the right information in the manual for Momentum(my guess is I'm searching for the wrong thing).

Any help is greatly appreciated.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top