Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

AnsysElectronics Desktop (HFSS) solvers- HF3d error code 149

Status
Not open for further replies.

parhamz

Newbie
Joined
Jan 17, 2023
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
61
Hello all,

I have Ansys electronics desktop 2022 R2 working on ubuntu 20.04 . I made my mesh pretty coarse and I have a lot of RAM and CPU power on my local machine and I still get this error. No matter I use direct solver or iterative solver I get the same issue. What is the solution for this problem ?

The solution happens after the mesh is created I can see the mesh and the analysis convergence for the S parameter requirement. The moment hf3d starts solving for sweeping frequency it fails.

Here is the detail of the error that I get: Transition_wr75 (Modal Network)
[error] Solving frequencies ... (Nondomain solver), process hf3d exited with code 149. (1:55:20 PM Jan 17, 2023)
[info] A discrete frequency sweep with 17 point(s) has been started using HFSS - Solving Distributed. (1:55:42 PM Jan 17, 2023)
[info] Discrete frequency sweep complete. (1:55:42 PM Jan 17, 2023)
[error] Sweep first_analysis_sweep_coarse failed (1:55:42 PM Jan 17, 2023)
[error] Simulation completed with execution error on server: Local Machine. (1:55:42 PM Jan 17, 2023)
 

Solution
With your HFSS 2022R2 installation you can find a file called "What's new in Ansys Electronics Desktop 2022 R2" in the documentation folder. Under known issues you can find this section:
"611491 – Potential MPI failure on Linux (most commonly seen on Ubuntu) for distributed
simulations. Users can bypass the issue by setting the following environment variable
prior to opening Electronics Desktop and launching the simulation: I_MPI_SHM_LMT =
shm"

This environment variable solved the error code 149 issue while starting the MPI distributed solver on ubuntu machines for us. Therefore, the frequency sweep simulation can run on multiple cores, not just one.
update:

The issue is still not resolved but when I remove the frequency sweep to a from analysis, HFSS works fine.

The moment any frequency sweep analysis is created the error will come back!
 

From your description only one thing is clear that your simulation setup is not setup in a proper way and that is resulting in error can you share some pics of your simulation setup, your mesh definition and geometry. The problem has nothing to do with the mesh or computational resources rather it is related to the way the simulation is setup.
 

Thank you very much for replying to my question.

I am trying to make septum polarizer. Here is the screen shots of it: input
Screenshot from 2023-02-14 08-56-17.png

outputs:
Screenshot from 2023-02-14 08-56-33.png

Screenshot from 2023-02-14 08-56-55.png


I made a simple rectangular waveguide first and then carefully made the septum. No models/solids are overlapping with each other. all of the models are inside a model made out of vacuum which is Radiation boundary. This inside of the copper is the perfect electric boundary (inside the waveguide). because of the sharp corners of the septum the initial mesh setting is along the length and is very dense at ports and along the echolon form of the septum. the ports are defined as wave ports and i align the ports using integration line. i would be happy to answer anything if this is not a satisfactory answers to your question.



I created the same question on ansys forum I provide way more information over there. Here is link: https://forum.ansys.com/forums/topic/ansyselectronics-desktop-hfss-solvers/
I explained this way better in the above link Here what I think it is wrong: the idea is if I create a very simple rectangular wave guide and turn the "save the field and meshing off" I can solve it in parallel. If i increase the meshing quite extensively the parallel hf3d would not work. (I have 4*32 GB RAM in this system ) Now when i look at each hf3d process id, the moment I have a question which requires more than 16 GB of RAM so part of the so the first hf3d will get the top portion of first RAM and the second one will have part of the first RAM and the second RAM. When this happens the hf3d process stops. Having said all of that this might not be the case. I am not sure and open to try anything. It would be great If you look at the provided link in ansys forum.

Regards,
Parham
 

If you do not mind please share with me the HFSS file as it would be more easier and more time efficient for me to have a look at the model and understand if I understand the problem and can help you to resolve it. Based on my experience a simulation setup in proper way does not require insane amount of sources and to design something you do not need so refined mesh at the start as that could be the last step when you really are sure about the model and just need to generate the final results
 
I have run your simulation just by making the following changes
1. I removed the specific mesh definitions as from my point of view it was sort of over kill I mean 0.5 mm length and use the slider setting
2. Despite so tight mesh definition you did not enabled the "Apply curvilinear to all curved surfaces"
3. In the simulation setup under the options tab I changed the order of basis function to 2nd while you were using the first for some unknown reasons
and that is all and I run the simulation and it worked
 

Attachments

  • ED2.png
    ED2.png
    120.3 KB · Views: 117
  • Eda1.png
    Eda1.png
    289.8 KB · Views: 128
Thank you for getting back to me. I followed your steps as you mentioned above. It is for sure running much faster. I read more about mesh refinement and curvilinear meshing and it gave me the same result as before. (the result are generated using 1 core which leads me to my next point.)

Having said that, when I followed your steps my problem is still in place. Meaning: Once the adaptive mesh converges, and frequency sweeping starts, it does not solve the problem in parallel for multiple frequencies . It should solve 4 frequency in parallel but the error code 149 comes again. when I limit the HPC to 1 core, it solves with one core. which is sequential.
Here is the screen shot of the error when frequency sweeping starts.

Thank you for your time.


PS: I am 100 percent certain that this is not licensing issue.

Screenshot from 2023-02-16 10-16-47.png
 

As you can see even in the picture you shared there are additional slowly decaying modes (degenerative modes) which always makes the simulations setup messy. I would suggest you to get rid of this problem and then try to proceed with the next steps. As per my experience if the ports support such modes then simulation does not converge and keeps on jumping between one solution to the other.
 

With your HFSS 2022R2 installation you can find a file called "What's new in Ansys Electronics Desktop 2022 R2" in the documentation folder. Under known issues you can find this section:
"611491 – Potential MPI failure on Linux (most commonly seen on Ubuntu) for distributed
simulations. Users can bypass the issue by setting the following environment variable
prior to opening Electronics Desktop and launching the simulation: I_MPI_SHM_LMT =
shm"

This environment variable solved the error code 149 issue while starting the MPI distributed solver on ubuntu machines for us. Therefore, the frequency sweep simulation can run on multiple cores, not just one.
 
Solution
Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top