Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Altium Designer 14 DRC Error: Silk to Board Region Clearance Violation

Status
Not open for further replies.

slayer2211

Newbie level 4
Joined
Feb 19, 2015
Messages
7
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
72
Hello All,

I am pretty much new to Altium Designer and just started to use it to design PCB. , Whenever I run the DRC, I always encounter the silk to board region clearance error. It gives me the message: Silk to Board Region Clearance (Out of Silk Screen Region) Text "" (-138.33mm,-2.3mm) Top Overlay Silk Primitive on Board without silk screen. When I click the message for detail, it just point me to empty space outside the region. Does anybody know what this actually is? How do I get rid of this since it's been bugging me for quite a while.

Thanks.
 

Kick

Full Member level 6
Joined
Sep 27, 2010
Messages
341
Helped
16
Reputation
32
Reaction score
15
Trophy points
1,298
Location
India,Bangalore
Activity points
3,149
Do 1 thing go to properties of the component in layout and uncheck hide option of comment,then you can see the value of component outside of the layout. That's the reason of error. I think you can disable that option.
 

ArticCynda

Advanced Member level 1
Joined
May 8, 2013
Messages
424
Helped
82
Reputation
164
Reaction score
81
Trophy points
1,308
Activity points
4,047
Either disable that design rule, or as Kick suggests, delete any silk layer primitives outside the board outline.
Practically it won't make a difference though, silk doesn't affect the electrical integrity of your board, and all PCB manufacturers I know will simply discard any silk primitives outside the board outline.
 

slayer2211

Newbie level 4
Joined
Feb 19, 2015
Messages
7
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
72
I see. Although I did not enter any text on the comment, it still detect the "empty" string outside the board. For some reason when I place a footprint, the comment x and y location goes out of region by default. So I just enter any dummy comment, unhide it, and drag it back inside the board region, delete the text, and hide it again. That fixed the error. Otherwise disable the silk to board region clearance design rule works too.

Thanks a lot guys!
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top