Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

ADE7758 WFORM Register

Status
Not open for further replies.

Hanskarl2000

Newbie level 3
Joined
Sep 12, 2009
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Switzerland
Activity points
1,304
wform

Hi
ADE 7758 has a WAVEFORM register for voltage or current or active power or reactive power or apparent power. The value is selected in WAVEMODE register.

But whatever I select in WAVEMODE, I get zero in WAVEFORM.

(The AIRMS and AVRMS work fine).
Another problem is AWATTHR. The values are undefined. I do read the register in 100 ms cycle and LCYCMODE ==0xC8, that means reset at reading.

I have any experience with ADE7758, can you give me a hint.
Best regards
Hans
 

I have your same Problem. I have made a test circuit.
to test the voltage I use a transformer from 220v~/9V~ and resistors 25k and 1k. However, when i read the waveform régister

Write1byte(0x15,0x04);//Write to ADE Wavemode register and I check it
//wavemode = 0x04 successfull
Read3byte(0x12);Read WFORM ,and the data read is 0x000000 :(( so sad
93_1254398539.jpg
 

Hi tranthudo

Thank you for sharing with me the same bad experience. Hopefully we will find somebody who has experience with ADE7758.

Best regards
Hans
 

@Hanskarl2000: So you can read AVRMS?. I haven't test to read AVRMS because i think if i can read wform, I can do well all other module.
I have uncomfortable about the way Analog present this ADE7758 datasheet.
Acording to this page : bit 2 - 4:WAVSEL (default value =0).
So I think bit in red area is the zero bit of WAVSEL[2]
and the 3rd bit of WAVMODE register? Is it right?



Added after 51 minutes:

I have just tested to read AVRMS and it's successfull. Thanks
 

When i did read o wform whithout a interrupt of ADE7758, i did read 0x00.
I can read only when the interrupt WFSM happen.

#define WAVMODE 0x15
#define PHSEL_FA 0x00
#define DTRT_3kSPS 0x60
#define WAVSEL_VAR_MO 0x0C
#define Fase 0x00

u8 temp = PHSEL_FA | Fase | WAVSEL_VAR_MO | DTRT_3kSPS;
MA_Write_Data( WAVMODE, &temp , 1);

/* Enable Int MSP430 */
__enable_interrupt();
/* Enable Int of ADE7758 */
Enable_Interrupts( WFSM );

/* Wait Int of WAVFORM */
while( !IsFlagIntStatus );
IsFlagIntStatus = RESET;

/* Read 3 bytes of ADE*/
PReactive = MA_Read_Data( WFORM, 3 );

Disable_Interrupts( WFSM );
__disable_interrupt();

thanks for attention.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top