Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] A solution: PL2303 Error Code 10 and how to solve it on Win7 64-bit

Status
Not open for further replies.

sky_123

Advanced Member level 4
Joined
Feb 26, 2011
Messages
1,170
Helped
279
Reputation
566
Reaction score
273
Trophy points
1,363
Activity points
9,598
I thought it worth pasting here, since possibly many people use USB-Serial converters. I have several different types, and the PL2303 ones don't work on Win7 64-bit. Maybe they are not "genuine" PL2303 chips inside. Mine were purchased from Maplin UK.

Anyway, the root of the problem is that the most recent drivers are incompatible with some of the PL2303 USB Serial converters, and the older (working) driver cannot be found on official sites (maybe to encourage people to purchase new USB to Serial interfaces).

First step is to uninstall from Device Manager if you have already plugged in the device. The drivers that you need can be found via google; search for a file called
PL2303_Prolific_GPS_AllInOne_1013.exe (file size was 3,052,939 bytes).
Once found, double-click to install. After installing, the PL2303 USB Serial converter _may_ work on Windows 7.

If you still get an error marker against the device in Device Manager (and possibly an Error code 10 if you look at the properties of the device) then the problem is, that Windows is still loading the incorrect driver.

The trick to getting it to operate is a little convoluted but it works:
Firstly, confirm the symptom by looking at the Driver settings in the Device Manager. If the Driver Version is higher than 3.3.2.105, then Windows is picking up a more recent driver.
To solve this, you need the help of a text editor that can "Find in Files". An example is UltraEdit. Use the editor (or an alternate method) to search for all *.inf files in C:\Windows\inf that have the following text inside them "Prolific USB-to-Serial". My search found two files; one was called oem42.inf and the other was called oem43.inf. The numbers will vary.
Inspect the files in a text editor. In my case, the oem42.inf file was the culprit; it contained this text on around line 12: DriverVer=11/12/2012,3.4.42.258 The oem43.inf was the result of installing the
PL2303_Prolific_GPS_AllInOne_1013.exe software, and it had this correct text:
DriverVer=10/27/2008,3.3.2.105
So, I needed to disable the oem42.inf file because it refers to the more recent driver that doesn't work. The easiest way to disable it is to change the filename from oem42.inf to oem42_inf_backup (without the .inf suffix).
After that, plug in the USB Serial converter, and the correct .inf file will be used to install the driver. Success.
 

hardyethan

Newbie level 6
Joined
Mar 1, 2009
Messages
13
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,283
Activity points
1,374
Hi sky_123,

You saved a lot of frustration for me.

The solution you presented worked like a magic spell.

thanks..
 
Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top