Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Xilinx 7.1 synthesis problem

Status
Not open for further replies.

pankaj

Member level 3
Joined
Jun 6, 2001
Messages
61
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,286
Activity points
340
Hello,

did anybody find a problem with Xilinx CPLD synthesis with its 7.1i version.
I have a design in XC9572XL series. What I have found is that it is synthesising a inverting gate for a buffer. In simulation and the reports everything is fine, but only when the design is downloaded that this anomaly is observed. The same design works fine when synthesised using 6.2 or 6.3 version.

Pankaj
 

Renjith

Full Member level 3
Joined
Jan 3, 2005
Messages
173
Helped
15
Reputation
30
Reaction score
6
Trophy points
1,298
Location
India
Activity points
1,710
Hi pankaj,
if it has synthesised something wrong, then u will get the wrong results displayed on your post synthesis and place and route simulation.

u can put this problem to xilinx.
 

Sparc

Member level 5
Joined
Apr 11, 2005
Messages
90
Helped
16
Reputation
32
Reaction score
2
Trophy points
1,288
Location
out of reach..
Activity points
2,295
If you are getting what you expected as output, this is not an anomaly. Synthesis tools do many opimizations on to achieve the efficient implementation for your functionality. So, the buffer which you might be (mis)interpreting as an inverting logic; either your design is also using the "not" of that logic somewhere in the design OR it might again be corrected by again inverting it back to form the buffer-Reason for this can be: Synthesis tool does it's best to utilize the available resources to it's max. You try out setting different optimization goals and can have a deeper look into the synthesis tool.
 

priyaphule

Junior Member level 1
Joined
Jun 7, 2005
Messages
17
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,436
hello pankaj,

have u got the solution for the problem

i am also getting the same problem with xilinux 7.1i version

on test bench waveform i am getting the expected result but after downloading i am getting inverting output for and and nor, not get while for or and nand get it work fine

is there any inverting buffer logic behind it

please send PM to me regardingly

Priya
 

kang_computer_01

Junior Member level 1
Joined
Apr 19, 2005
Messages
18
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,429
so i have problem to can't save testbench waveform can every body help
 

soccer

Full Member level 3
Joined
Jul 30, 2004
Messages
172
Helped
4
Reputation
8
Reaction score
1
Trophy points
1,298
Activity points
1,186
the buffer which you might be (mis)interpreting as an inverting logic; either your design is also using the "not" of that logic somewhere in the design OR it might again be corrected by again inverting it back to form the buffer-Reason for this can be: Synthesis tool does it's best to utilize the available resources to it's max.
 

MRFGUY

Full Member level 1
Joined
Sep 16, 2003
Messages
98
Helped
9
Reputation
18
Reaction score
3
Trophy points
1,288
Activity points
1,049
Actually this topic sould be closed. Because echo47 give the key point for Xilinx 7.1i logic error. I also faced the same problem and follow echo47 link. Finally install service pack3 and all locgic inverting problems are solved.
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top