Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Vitesse VSC8211 PHY in "GMII to 1000BASE-X" mode

Status
Not open for further replies.

Black Jack

Full Member level 4
Joined
Dec 2, 2003
Messages
236
Helped
14
Reputation
28
Reaction score
3
Trophy points
1,298
Location
UKRAINE
Activity points
1,817
gmii phy

Vitesse VSC8211 PHY in "GMII to 1000BASE-X" mode problem
Could you help me, please?
We have 2 VSC8211 PHY on board connected with Zarlink MVTX2804A switch
via GMII.
We use both 1000BASE-T and 1000BASE-X I/F on PHY`s and switch
between them by writing Conf.Registers.
1000BASE-T work. All test loops work properly.

For 1000BASE-X we connect PHY#1 with PHY#2 via SFP Fiber Module`s
In PHY#2 we make external loop. Communication establish in this case.
But if we connect two PHY without external loop, connection work only in one direction. This situiation repeated with external switch with SFP module.

I think that problem with auto-negotiation in 1000BASE-X mode,
but I`m not understand how avoid this problem...

-- Best Regards,
-- Black Jack
 

ilikebbs

Advanced Member level 4
Joined
Nov 30, 2002
Messages
104
Helped
3
Reputation
6
Reaction score
1
Trophy points
1,298
Activity points
705
1000base-x phy

"connection work only in one direction"
what does it mean?

you can try the following steps:
1. disable the spanning-tree protocal
2. restart the auto-negotiation
3. read the link parter status if the phy support
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top