Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

very urgent - problem with -IAR

Status
Not open for further replies.

grittinjames

Advanced Member level 1
Joined
Jun 1, 2006
Messages
483
Helped
44
Reputation
90
Reaction score
32
Trophy points
1,308
Location
bangalore india
Activity points
3,985
hai all

im getting a offset of 1000h in codes which is generated by iar
i heard some c startup setting shuld be requered for this
what are the initial sett up requred for cstart up
plz help me
 

gorkin

Advanced Member level 1
Joined
Feb 27, 2002
Messages
422
Helped
13
Reputation
26
Reaction score
5
Trophy points
1,298
Location
brazil
Activity points
3,384
Hello my brother!
Firt, for help You, we need more SOME information, in Yors next post, provide ALL possible informations.

For try answer this post, we need know:
- What microcontroller type is used?
- What version of iar is used: What version?
- What platform?
- You modified any XCL or other configurationn files?

Gorkin
 

SphinX

Advanced Member level 3
Joined
Jan 25, 2002
Messages
822
Helped
58
Reputation
116
Reaction score
29
Trophy points
1,308
Location
EGYPT
Activity points
7,051
Salam,

Look to the Linker command file (XCL). In this file you can specifiy all code and data segments locations in memory and stack size.

You can customize this file for your needs.

Project options --> Linker --> config --> load the xcl file (after edit the orginal)

Read IAR Compiler manual for more info (Placing Code and Data chapter)

Bye
 

    grittinjames

    Points: 2
    Helpful Answer Positive Rating
Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top