Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

transmission line issue

henry kissinger

Member level 2
Joined
Nov 19, 2021
Messages
43
Helped
0
Reputation
0
Reaction score
0
Trophy points
6
Activity points
435
The transmission used here has characteristic impedance of 60Ohm at the voltage pulse Tr=0.1 nsec
I am using a repeating voltage pulse to get the information of the characteristic impedance of the transmission line.
When the pulse drops to 0.3V, the node drops to 0.558V because at this short period it is seeing the transmission line as a resistor of 60Ohm
I learnt that this short period is the time for the signal to travel across the transmission line.

However if I increases the length of transmission line from 5cm to 20cm, the first pulse seems ok, the time it takes to travel across the line is 4 times and it is still dropping to 0.558V. But the successive pulses are not accurate, which deviates from 0.558V and have a weird shape.
What causes this I still don't understand? and how should I fix it? to let 20cm usable.
1670021147810.png

1670021106158.png

1670021118098.png
 

henry kissinger

Member level 2
Joined
Nov 19, 2021
Messages
43
Helped
0
Reputation
0
Reaction score
0
Trophy points
6
Activity points
435
The transmission line has characteristic impedance of 60 Ohm.
How to explain that the voltage at 'node' oscillate between 0.558V(1-0.7*(60/95)) and 1.442V(1+0.7*(60/95)) ?
I only know that in stable situation it should be 1V, but what it is confusing is during the transition of the pulse.
1670043768166.png
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
50,788
Helped
14,600
Reputation
29,475
Reaction score
13,680
Trophy points
1,393
Location
Bochum, Germany
Activity points
290,847
What do you expect? You are driving a shorted transmission line and have no correct source termination. Results in multiple reflection that superimpose during the pulse train. What's the intended waveform?
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
50,788
Helped
14,600
Reputation
29,475
Reaction score
13,680
Trophy points
1,393
Location
Bochum, Germany
Activity points
290,847
The waveforms in your simulation are smoothed, most likely due to limited time resolution in the simulator settings. To see the response of an ideal transmission line, you should use finer resolution, as in the below LTspice simulations. I don't know the substrate parameters and respective exact transmission delay of your circuit, I tried to create similar delays.

1670079860626.png


1670079947224.png


Here the voltage steps caused by reflections running back and forth the line van be seen much better.

To predict the step voltages, you need to calculate the reflection and transmission factors for the discontinuities in the transmission line circuit. First discontinuity is from pulse generator to TL, Rs=35, Rl=60, T=60/95 as you calculated. Second discontinuity is at the shorted line end, R= -1, voltage step is running back inverted. Third discontinuity is line to source, Rs=60, Rl= 35. R=(35-60)/(35+60)=-0.26, T=2*35/(35+60)=0.74. Respectively -0.44 V pulse is partly transmitted and partly reflected again. See also https://en.wikipedia.org/wiki/Reflections_of_signals_on_conducting_lines#Discontinuity_along_line

With each roundtrip, the pulse is attenuated to about 1/4. With short transmission line, the multiple reflections have almost faded away before the next source edge. In case of the long line, the reflections are still enduring, causing a more complex superseeded waveform.
--- Updated ---

A detailed discussion can be e.g. found in Hall/Heck, Advanced Signal Integrity for High-Speed Digital Designs, Paragraph 3.5 Transmission-Line Reflections.
 
Last edited:

henry kissinger

Member level 2
Joined
Nov 19, 2021
Messages
43
Helped
0
Reputation
0
Reaction score
0
Trophy points
6
Activity points
435
Thank you for great and explain. I totally get your concept!
but Can you explain a little more why the original voltage change decay to 26% after each round trip?

Initially the voltage at node get reflected and remain 60/(35+60) =63%
but why it decay to 26% after a round trip? I dont get it how T=2*35/(35+60)=0.74 comes from?
 

henry kissinger

Member level 2
Joined
Nov 19, 2021
Messages
43
Helped
0
Reputation
0
Reaction score
0
Trophy points
6
Activity points
435
The transmission used here has characteristic impedance of 60Ohm.
I am using a repeating voltage pulse to get the information of the characteristic impedance of the transmission line.

When the pulse drops to 0.3V or goes back to 1V, Initially the voltage at 'node' changes by 0.7*60/(35+60) = 0.442V, why is it calculated this way? I learnt the reflection coefficeint is calculated as ZL-Z0/ZL+Z0 tho, which is different to how I get the 0.442V.
also why it decay to 26% after each round trip? How do I get this result based on calculation with reflection coefficient?
1670115323431.png

1670115487079.png
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
50,788
Helped
14,600
Reputation
29,475
Reaction score
13,680
Trophy points
1,393
Location
Bochum, Germany
Activity points
290,847
Round trip attenuation is the product of R at both ends, -1 and -0.26, as calculated above. The voltage you see at the line input isn't the reflected voltage, it's the sum of original and reflected pulse, 2*Z2/(Z1+Z2), see also Wikipedia link above. Between source and line input, factor 2 doesn't occur because you relate the measurement to unloaded rather then 35 ohm loaded voltage. Instead you get the simple voltage divider for transmitted pulse.
 

LaTeX Commands Quick-Menu:

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top