Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Strange behavior of AD7730

Status
Not open for further replies.

_Mark81_

Newbie level 6
Joined
Jul 4, 2010
Messages
13
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,281
Location
Inverigo (CO) - Italy
Activity points
1,395
Hello,

this is the first time I write here. I apologize if my English is not so good, but it's not my primary language.

I experience some problems with the AD7730 and a small AVR. I read through the older threads in this forum but I wasn't able to fix the issue.

This is the schematic:

2crkemf.png




Some key points:

- I can successfully read the AD7730 registers but it seems I can't write them.

- I don't see any wave on CLK pins. IN is low and OUT high (steady)

- if I write to a register (eg. DAC or filter) I always read the initial value.

- if I start a conversion or a calibration I see the RDY pin that goes low for 250 ns and then returns high.

With these elements may you help me to find out the problem?

Thanks
Marco
 

bobcat1

Advanced Member level 4
Joined
Jul 10, 2002
Messages
1,288
Helped
99
Reputation
198
Reaction score
34
Trophy points
1,328
Activity points
8,547
HI

First disconnect SPI Din & Dout and short them together to test the SPI link

if its working (by sending a byte and reading it back at the same time)

It is most likely to have a timing problem connect SPI signal to 2 ch scope and test the signals for sync (CLK with DIN ,CLK with Dout,CLK with CS etc...)

All the best

Bobi

The microcontroller specialist
 
  • Like
Reactions: szovhoz

    szovhoz

    Points: 2
    Helpful Answer Positive Rating
    V

    Points: 2
    Helpful Answer Positive Rating

_Mark81_

Newbie level 6
Joined
Jul 4, 2010
Messages
13
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,281
Location
Inverigo (CO) - Italy
Activity points
1,395
Thanks for your answer.
Anyway, I've just found out the problem in the meanwhile I was reading your post.

Look at the schematic: I forgot to connect the GND to AGND!
That's why it didn't work!

Marco

Added after 2 hours 47 minutes:

Ok, now I can successfully read and write the registers of AD7730.
I performed the internal calibration, wrote the right settings on filter and mode registers and I'm starting to acquire data.

I built a simple bridge with four 1% 470 ohm resistors so with a +5V supply voltage I get about 3 mV on the ADC input.

Anyway, I always read 0x000000 from data register.

My oscilloscope tells me that the configuration seems ok: the RDY pin goes down at 25 Hz, according to the filter settings. And the readback of all register is coherent with my settings.

I tried to change the settings, for example CHOP/NO CHOP, output rate, unipolar/bipolar, input range, with or without internal calibration, but the reading is always 0.

Again, I removed the bridge, so the input pins are floating. I expect a lot of noise. Instead, I get 0....


How to investigate on this?
Thanks again

Marco

Added after 2 hours 21 minutes:

Some progresses...

I set the wrong value in the filter register. Now its value is 0x800010, that is 50 Hz output and CHOP mode.

With my resistor bridge I get a count of 0x7C11 (16 bit, bipolar, range 80 mV) that is the value of the differential voltage applied at the ADC (about 2,8 mV).

Now the strange thing: if I reverse my bridge, I apply the positive voltage to the negative input and viceversa so I expect a count of about 0x83EF. Instead I read again 0x7C11.

I miserunderstood the datasheet?
 

    V

    Points: 2
    Helpful Answer Positive Rating

szovhoz

Newbie level 2
Joined
Sep 2, 2008
Messages
2
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,281
Activity points
1,290
this is because they do not use Bascom worked very well for me this spi bus!
 

    V

    Points: 2
    Helpful Answer Positive Rating
Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top