Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Square wave inverter cct not working plz help

Status
Not open for further replies.

mugheesnawaz

Member level 1
Joined
May 1, 2013
Messages
39
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
1,605
i want to make a 100w square wave inverter to drive a resistive load.power rating of inverter isn't an absolute criteria.firstly it isnt working.i have followed a circuit from internet but it isnt working.kindly help me figure out.

i have attached cct diagram and proteus design file

inverter.pngView attachment inverter.rar
 

brushhead

Full Member level 2
Joined
Jan 20, 2015
Messages
134
Helped
42
Reputation
84
Reaction score
42
Trophy points
28
Location
Shrewsbury, Shropshire, UK
Activity points
798
Hi,
Can you define not working? I would not drive two power FETs directly from a C-MOS 4000 device. I would require a gate drive IC in the way to drive them properly.

Rob.
 

Audioguru

Advanced Member level 5
Joined
Jan 19, 2008
Messages
9,017
Helped
2,105
Reputation
4,204
Reaction score
1,919
Trophy points
1,393
Location
Toronto area of Canada
Activity points
56,652
Your circuit is almost the same as mine. Mine works fine and since the frequency is so low then a gate driver IC is not needed.

Not many products today work properly when fed a squarewave.
 

Attachments


Tipu606

Full Member level 3
Joined
Jun 5, 2011
Messages
159
Helped
25
Reputation
50
Reaction score
25
Trophy points
1,308
Activity points
2,058
this is a basic circuit, why it should not work?
replace the IC and Mosfets and see
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top