Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

SOC Encounter Add IO Fillers issue

Not open for further replies.


dear all
i have a probleme with this function :
the latter function doesn't seem to work , I am newbie with encounter and I don't even know from where to begin dubugging.
here is the situation,
I created my floorplan, placed my core and io cells.
but when it comes to fill gaps between ios , I use this function:
addIoFiller -cell FILLER64UM
but no change in my floorplan
obviously there is enough room to place a 64 µm filler,
somebody told me that the attribute "situation" of the placed io cells should be placed instead of fixed , I tried this out but still this doesn't solve the probleme.

i tried addInstance -cell FILLER64UM -inst blaba -ori blabla, and this works ...
I can place a filler by addInst but not with addIoFiller ...

I am lost , if somebody experienced this kind of issues, and can give me some clues and hints to solve this problem, appreciate it

thanks in advance

What version are you using?
The last time I used was version 3.x but then, my co. upgraded to 6.x & now 8.x so I'm a bit rusty here.
Are there any warnings or errors?

It seems like your io fillers may not be recognised as io fillers.
Have these filler cells been specified as an io filler type to be used?
How about the .lef file - what CLASS are they defined as?

1. Try whether your die boundary and core boundary are different and Io Filler height is not more than the distance between die and core boundary (Just a sanity check)

2. Can you use options such as side, fillerOrient etc. with this command ?

-cell fillerCellName
[-prefix prefix]
[-side {n | w | s | e}]
[-from coord]
[-to coord]
[-row rowNumber]
[-fillerOrient R0 | R90 | R180 | R270 | MX | MX90 | MY | MY90]

I think I too faced this issue and got it resolved by specifying the orientation, location etc.


Not open for further replies.

Part and Inventory Search

Welcome to