Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Sms text filled with @ characters

Status
Not open for further replies.

Stralows

Newbie level 4
Joined
Feb 1, 2007
Messages
7
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,343
Hello

I am working on a project that requires a Siemens PLC to send a SMS via a Cinterion modem.

I can send and SMS with the proper AT+CMGS, only if I right the code on the Hiperterminal. If I run the same sequence of AT codes in the PLC the text sent is filled with “@” characters before the real text message.

What could be the problem? Do I have to specify to the modem the length of the message, or where it starts?

Thanks very much in advance!

Regards
 

Stralows

Newbie level 4
Joined
Feb 1, 2007
Messages
7
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,343
Thank you very much for the reply.

On the PLC side I have:
9600, 8 data bits, 1 stop bit and no parity
1000ms on expiry of character delay time
RTS/CTS with wait time for CTS=ON of 1000ms

On the modem side I have:
Auto bounding AT+IPR=0
And AT\Q3 for the RTS/CTS

I have notice that when I send a string with the ' at+cmgs= "number" $r$l "text to sent" $1A ' It sends the sms without the @ characters, but if I wait for the > charater and then send the text, it fills the sms with the @.

Thank you for the help
 

ckshivaram

Advanced Member level 5
Joined
Apr 21, 2008
Messages
5,070
Helped
2,149
Reputation
4,304
Reaction score
2,089
Trophy points
1,393
Location
villingen (Germany) / Bangalore
Activity points
30,094
make AT+IPR= 9600

connect modem to hyperterminal and see if the modem reads new message and prints on the terminal. make the same setting you have told on the terminal also and check the putput................
 

Stralows

Newbie level 4
Joined
Feb 1, 2007
Messages
7
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,343
Hello ckshivaram.

Thank you for the help.

I have solved the problem. I was sending to the modem a string with a fixed length. I thought that if the modem sense the end of the message by receiving the \r\l , so I could be sending always a 256 string.
It is true, but when you send the AT+CMGS= number \r \l . The PLC continuous sending the entire string and by the moment that the modem send the character > it starts to be receiving. So it was receiving the remaining of the previous string and when I send the message it was already full of @.

The solution was to send the appropriate length of the string and then wait for the >.

Regards,
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top