Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

SIM900 MMS command problem

Status
Not open for further replies.

rockregister

Newbie level 3
Joined
Apr 21, 2011
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,308
Hi all,

I've purchased SIM900-TE-C for MMS application. The SIM900 runs commands in "SIM900_AT_Command Manual V1.03" properly. But when I tried the MMS commands (SIM900_MMS_AT Command Manual V1.00), I always got "ERROR" result. The following is my information.

Country: Thailand
Mobile operator: AIS, DTAC

Result from ATI
SIM900 R11.0
Result from AT+GSV
SIMCOM_Ltd
SIMCOM_SIM900
Revision:1137B06SIM900M64_ST
Result from AT+CREG?
+CREG: 2,1,"9092","03D5"
OK
Result from AT+CGREG?
+CGREG: 2,1,"9092","03D5"
OK
Result of AT+CMMSINIT
ERROR
Result of AT+CMMSCURL="mms.mobilelife.co.th"
ERROR
Result of AT+CMMSCID=1
ERROR
Result of AT+CMMSPROTO="203.170.229.34",8080
ERROR
Result of AT+CMMSSENDCFG=6,3,0,0,2,4
ERROR
Result of AT+SAPBR=3,1,"Contype","GPRS"
OK
Result of AT+SAPBR=3,1,"APN","multimedia"
OK
Result of AT+SAPBR=1,1
ERROR
Result of AT+SAPBR=2,1
+SAPBR: 1,1,"10.38.174.64"
Result of AT+CMMSEDIT=1
ERROR
Result of AT+CMMSVIEW
ERROR

Is there any additional setting to enable the SMS command?

Thanks
Rock
 

horace1

Advanced Member level 5
Joined
Nov 18, 2008
Messages
2,123
Helped
596
Reputation
1,188
Reaction score
573
Trophy points
1,393
Location
Norwich, UK
Activity points
13,071
have you checked the signal quality with AT+CSQ
are you sure the modem you have is MMS enabled?
 
Last edited:

rockregister

Newbie level 3
Joined
Apr 21, 2011
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,308
have you checked the signal quality with AT+CSQ
are you sure the modem you have is MMS enabled?
The signal quality is 31. I'm able to use voice call and SMS function.

http://wm.sim.com/sim/wm/html/en/WMS/EDGE Module/ProductDetail.aspx?id=770

I bought the SIM900 module about a week ago.

The information on the SIM900 web site said the MMS function has available in July 2010. Is there anyway to check the manufacture date?
 

horace1

Advanced Member level 5
Joined
Nov 18, 2008
Messages
2,123
Helped
596
Reputation
1,188
Reaction score
573
Trophy points
1,393
Location
Norwich, UK
Activity points
13,071
electronic components can be in stock at distributers for months if not years - just had a PCB built to find to PIC24 we had used was an old revision and the IrDA did not work!
contact your supplier to enquire about the one you have - if you find it is not MMS enabled have a look at the manufacturers web site to see if can be upgraded.
 

Agha Khawer

Newbie level 1
Joined
Aug 16, 2008
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,285
SIMCOM released SIM900DZ without MMS Support thats why this is the problem.
I have purchased the SIM900DZ with MMS supported version, now all the MMS commands are working OK.
For more info & support you can contact me on agha_khawer@hotmail.com
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top