Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Sim300 Kit No Network detection

Not open for further replies.


Newbie level 4
Jan 16, 2011
Reaction score
Trophy points
Activity points
I currently used the sim300 kit with my atmega128 uniboard v1.1 . I burned the Chat program on the MCU and I connected the SIM 300 module with the UART0 of the MCU and connected the %V and GND pins of the module from the MCU 5v and grnd supplies .Also I tried powering it externally using a 7V battery.However the power led is the only one that glows with no network detection despite the fact that the simcard has been inserted.Please help :(

remove the controller board and power the gsm module.. you also specify what is the current rating of the power supply .. it should be 12Volts/1Ampere. check for ignition key on the board.. some modems have it....

Ok I was earlier using a 8v supply.I dont have access to 12v supply so used a 13v supply :( But still to no avail :'(

Not getting anything upon connecting it to the hyperterminal and neither are any of the at commands working .Yes I measured the current its 1A of current.

can you put the photo of the modem.. front view.. how many control buttons are there??

---------- Post added at 20:15 ---------- Previous post was at 20:13 ----------

what kind of antenna are you using????

posting the pic in 2-3 mins .Please wait

---------- Post added at 16:03 ---------- Previous post was at 15:46 ----------


1. Please use a serial cable instead of USB to serial cable...
2. remove SIM and then power on and see any output in the hyperterminal...

3. I dont see MAX232 IC in the modem board... maybe on the other side :)

seems to be cable problem...

I powered it externally using a 9V adapter and i am still using the same chat program which is being interface using uart0 of the atmega uniboard.This time I tried a different software instead of putty which seems to be the main problem behind the scene.Using Docklight now and the module is accepting AT commands now. However the network coverage still seems to be the issue .When i do AT+CSQ it returns +CSQ:30,0 and no sms or calls can be made.Please help me out :( :roll:

Your AT+CSQ is absolutely fine.. it means that the signal received by the module is good. that should not be a problem at all.. confirm that your SIM Is not password protected. try to make a call to the sim in the modem and see what is the response......

No the sim card isn't pass protected.I tried calling on the sim it says the number is switched off :| and besides tried sending sms it says +CMS 517 error neither is the Netwok LED blinking.

I have attached all the pics I could manage to take of the module with the only camera I ahve at present with me.However they are of poor clarity :(


  • 2011-07-01 01.44.14.jpg
    2011-07-01 01.44.14.jpg
    672.9 KB · Views: 110
  • 2011-07-01 01.44.42 (1).jpg
    2011-07-01 01.44.42 (1).jpg
    752.7 KB · Views: 107
  • 2011-07-01 01.44.55.jpg
    2011-07-01 01.44.55.jpg
    758.3 KB · Views: 106
  • 2011-07-01 01.45.04.jpg
    2011-07-01 01.45.04.jpg
    825.5 KB · Views: 109

I had the same 517 error because in my case the sim card's voltage was not present (1,8V measure between pins 1 and 4 of the sim holder), the problem was false contact in the gsm module.

Not open for further replies.

Part and Inventory Search

Welcome to