Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

SIM 900 not responding to AT commands and returning strange characters

Not open for further replies.


Junior Member level 1
Feb 21, 2007
Reaction score
Trophy points
Activity points
Hi All,

I am having a SIM900 module. **broken link removed**

I was trying to communicate it with and display the response in LCD. But somehow I was having some issues of getting LCD working all the time. In the mean time I connected the USB of the GSM module with the PC and used the GSM Utility Software provided by them to communicate. So it was like usb-software connected to PC and rx/tx was connected to PIC as well. Inshort GSM was driven by both at that time.

After some time the GSM module stopped responding and it was not responding with OK for AT or any other commands even with the GSM Utility Software . Previously it used to send OK when using this. Seems something happened to the GSM module.

I tried to set the baud rate to 9600 again using AT+IPR . When AT is sent first time some ? was returned , when AT is sent second time OK was received.

Once OK was received second time as per the someone who mentioned to set AT&W I did that . Even then nothing happened. I even tried AT&F and AT&W to reset to factory .even then nothing happened.

Now every time for executing a command I have to send it twice. First it will return some strange letters, second time it works. What exactly I need to do make it as before or completely reset the module so only on the first attempt it returns the values properly

Please do help me

Not open for further replies.

Part and Inventory Search

Welcome to