Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Sense amplifier in Cadence

antlhem

Member level 1
Joined
Dec 8, 2016
Messages
39
Helped
0
Reputation
0
Reaction score
0
Trophy points
6
Activity points
348
Hi, I am making a sense amplifier in Cadence but is not providing the right Vout. Every time I enable the sense amplifier does not change much, just outputting a voltage of 4.3V, which is very close to Vdd=5V. It suppose to output the difference of inputs multiplied by a gain (BL and NOT_BL) which are the bit lines in a memory, such as DRAM. I am attaching the diagrams I am following and the schematic and results from Cadence. Any advise on how to make the sense amplifier work correctly?
Cross-coupled sense amp diagrams from book.png


The following is the schematic from Cadence and results
Sense amp circuit with big tech not working.PNG
Sense amp results with big tech not working.PNG
 
Last edited:

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
48,284
Helped
14,228
Reputation
28,717
Reaction score
12,923
Trophy points
1,393
Location
Bochum, Germany
Activity points
279,601
Vout is expected to go to high level with BL > nBL. Why don't you apply opposite polarity or check nVout?

Not sure if you have set reasonable circuit parameters, but you should at least see a reaction.
 

LaTeX Commands Quick-Menu:

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top