Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Sending data to Atmega32 through Zigbee

Status
Not open for further replies.

vterminater

Junior Member level 1
Joined
Jul 16, 2010
Messages
19
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,413
i am doin a project where the sensors send some data to atmega32 through xbee....atmega32 then performs some actions based on it...
I am a newbie to xbee n don understand wireless protocols pretty well
can anyone gimme an example program(will help my understanding) so that i can get started with it? 8O
 

geobabu

Member level 2
Joined
Jul 17, 2008
Messages
53
Helped
8
Reputation
16
Reaction score
8
Trophy points
1,288
Activity points
1,605
Re: Atmega32 with zigbee

Hope you have done all the connections properly and good with the atmeg's UART communication. For starting with the Xbee, better configure it to work in transparent mode (AT). (If you are using Digi's or Maxstremes it can be done with X-CTU s/w) . In transparent mode, whatever data getting in the DIN pin transferred wirelessly and any wireless data is captured, the data will be available at the modules DOUT pin. Once this done you can try with API mode. A lot of helpful stuffs are avilabe on net, just google it.
 
Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top