Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Run to time in SPICE

Status
Not open for further replies.

sajjade

Newbie level 6
Joined
Apr 24, 2015
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
101
Can anybody help me regarding the run to time setting in PSPICE. Results are not consistent with different "run to time setting" in edit simulation setting window. I am simulating MOSFET base CMOS circuits using SPICE models. How to set proper run to time to get accurate results.
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
48,275
Helped
14,226
Reputation
28,713
Reaction score
12,920
Trophy points
1,393
Location
Bochum, Germany
Activity points
279,560
Run to time settings will be usually suggested by the simulation problem, e.g. you'll want at least see several switching cycles, or a circuit should reach almost steady-state.

You can most likely get consistent results by specifying a maximum step size in a low ns or even sub-ns range, at cost of increased simulation time.
 

sajjade

Newbie level 6
Joined
Apr 24, 2015
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
101
Thank you very much FvM.
It worked nicely.
I am getting consistent results. My simulation run time is within 20ns. I can afford to set sub nanosecond step size.

with regards
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top