Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

REDHAT 9.0 work with EDA tools

Status
Not open for further replies.

alliance

Junior Member level 1
Joined
Mar 24, 2003
Messages
17
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
200
Dear all,

Do you use Redhat 9.0 ti install and run commerical EDA tools?

I cannot install Cadence IC 5.0 on Redhat9.0.

Does anyone install success ?

Can we build a check list for Redhat 9.0

Linux-platform EDA_ tools OK/Fail
----------------------------------------------------------
Redhat 9.0 Cadence IC 5.0 Fail
 

xworld2008

Full Member level 4
Joined
Dec 13, 2002
Messages
231
Helped
18
Reputation
36
Reaction score
14
Trophy points
1,298
Activity points
1,801
cadence ic50 can not install in rh9.0,try rh7.2.
 

Zerox100

Full Member level 6
Joined
Mar 1, 2003
Messages
320
Helped
21
Reputation
42
Reaction score
10
Trophy points
1,298
Activity points
2,508
RH 7.2 is good OS for major EDA tools (linux version eda tools).
 

mart242

Junior Member level 1
Joined
Mar 13, 2003
Messages
18
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
142
Anyone knows why the EDA tools wouldn't be compatible with RH9 or the latest Mandrake?
 

must

Junior Member level 1
Joined
Apr 4, 2003
Messages
16
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
108
install those 7.3 backward compatibility libraries

compat-gcc-c++-7.3-2.96.118.i386.rpm
compat-gcc-7.3-2.96.118.i386.rpm
compat-libstdc++-7.3-2.96.118.i386.rpm
compat-libstdc++-devel-7.3-2.96.118.i386.rpm

to see if it works.
 

tlihu

Full Member level 6
Joined
Jan 2, 2002
Messages
336
Helped
18
Reputation
40
Reaction score
13
Trophy points
1,298
Activity points
2,258
mart242 said:
Anyone knows why the EDA tools wouldn't be compatible with RH9 or the latest Mandrake?
I'm using IC5 on RH9. It's working w/ minor warnings.
 

Ansunamu

Advanced Member level 4
Joined
Oct 19, 2001
Messages
115
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,296
Activity points
845
Not only Cadence tool

I tried the Modelsim on the RH9.0 also can not work . I can not invoke it . I thought that if you need to use the EDA tools on RH , you should use the RH7.3 or RH7.2 . I already tried lots of the tools on RH7.2 and RH7.3 , all of them are work well until today except some of tools ask for newer gcc compiler or qt library . In that case , you only need to download the source code and compile on your RH .
 

alliance

Junior Member level 1
Joined
Mar 24, 2003
Messages
17
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
200
What tools need newer gcc compiler or qt library?

What's RH 7.3 gcc version?
 

Ansunamu

Advanced Member level 4
Joined
Oct 19, 2001
Messages
115
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,296
Activity points
845
Some of the System C tools

Some of the System C tools will need it . The gcc version of RH7.3 is 2.96
 

saho

Member level 3
Joined
Apr 4, 2003
Messages
59
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
1,072
More Detail on Linux Setup

Hello.

Ideally, I would like to install latest release of Redhat Linux installation on my PC. Oh, I like what I see on Redhat Linux 9.0. To the worse, I would accept Redhat Linux 8.0.

I had tried installing version 7.2, the install didn't go smoothly as I have few hardware issues. This is because my PC is brand new.

I would REALLY appreciate if some of you (linux EDA tool expert) out there could possibly compile a NEWBIES tutorial on EDA tool setup on latest Linux (preferably Redhat distribution). What I have found PROBLEMATIC is that most EDA vendors only support Redhat Linux 7.1 and 7.2. Now with latest Linux installed (other than supported), everything SCREWED-UP and software application would NOT execute.

Honestly, I have no ideas on how to re-install those OLD Linux software library packages onto the NEWER Linux install. I am LINUX beginner. Bear with me!

perhaps, I am VERY annoying and demanding. I am keen to learn Linux and more specifically running EDA tools (wider range of tools) which are NOT offer for Windows NT/2000/XP platform.


best regards,
SAHO
 

geconom

Full Member level 3
Joined
Feb 12, 2002
Messages
179
Helped
6
Reputation
12
Reaction score
3
Trophy points
1,298
Activity points
1,464
You are not annoying and demanding. Since Linux is not a commercial product you have to work a little bit harder for support on newer devices. However, sooner or later solutions come out from others who have the same problems and through the Internet they are spread all over the world. Also EDA companies try to make new versions of their software compatible with the latest linux distributions but his takes some time. I think synplicity is officialy supporting RH 8.0 now. In the mean time you have to be lucky to find someone with similar problems who will be able to send you ideas about how to overcome yours. And elektroda is the right place to ask and search for them.
Unfortunatelly I am running very well with RH 7.3, I have installed Synopsys, Mentor, Synplicity, e.t.c and I do not want to bring trouble by changing the OS. However, keep asking!
 

paparas

Junior Member level 1
Joined
Sep 11, 2002
Messages
18
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
67
Why don't you try Mandrake 9.0 (haven't tried 9.1 yet)?
The only problem is that you don't see the initial graphical
setup interface. Also upgrade to the latest graphic card drivers
(tested for NVidia cards) to solve the 256 colors only problem
of the Cadence enviroment
 

sisari

Junior Member level 3
Joined
Sep 3, 2001
Messages
26
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
122
SuSE Linux 8.0 a good environment for EDA tools

Installed IC 5.0 an works fine ( 8 or 24 bit color mode ). SuSE 8.0 works fine with hardware (lot of good drivers compared to RedHat 8.0 or 7.2)
With Modelsim or Synopsys ..no problem ! ;-)
Only Hspice linux version still not work on SuSE ...

Try and you'll see !
 

cmh

Newbie level 1
Joined
May 10, 2003
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
8
Installed I.C. 5 can work smoothly on Mandrake 9.0, but
u need set the 24 color resolution mode.
 

viahole

Junior Member level 3
Joined
Dec 31, 1999
Messages
30
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
168
I have read some where that new "*.so*" liberys contain all of the old data + new stuff, so somtimes setting up progz. on a new vertion rh -suse whatever linux dist. is a matter of check what vertion of libs. your progz. need and them symlink them to there newer vertion.
I don't have any of subj. but have solve similar probs. with that solution.
 

Kermit76

Member level 2
Joined
Oct 26, 2001
Messages
47
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
251
Thats great! I really want to use eda tools in Linux, but i don't have any linux version of the eda tools.

Please some one help me get eda tools for linux. Whats a good place for linux eda tools?

Thanks
 

geconom

Full Member level 3
Joined
Feb 12, 2002
Messages
179
Helped
6
Reputation
12
Reaction score
3
Trophy points
1,298
Activity points
1,464
If you do not have something specific to do with 9.0 or you are not willing to "dig" for solutions, why not? 7.3 is a very good OS. Or wait for the next versions of EDA software that will support 9.0 (by then RH may have released 10.2 ofcourse!)
 

pado777

Junior Member level 2
Joined
Jul 13, 2001
Messages
20
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
78
slackware 9 good!!!

It works well.
 

FNK

Member level 3
Joined
Jan 25, 2003
Messages
67
Helped
5
Reputation
10
Reaction score
5
Trophy points
1,288
Activity points
470
Kermit76
You can try downloading Redhat linux from redhat.com. There are older versions available there too. Remember to use FTP server that is close to your desitnation
 

Kermit76

Member level 2
Joined
Oct 26, 2001
Messages
47
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
251
Thanks FNK but I'm already using Slackware linux. I'm looking for eda tools such as IC5.0, or M/e/n/t/o/r tools. I don't know where to obtain linux version of the tools. :cry:
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top