Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Question about for loop

promach

Advanced Member level 3
Joined
Feb 22, 2016
Messages
865
Helped
1
Reputation
2
Reaction score
2
Trophy points
18
Activity points
8,451
Why is line 479 executed for 0x3F times ?

The system does not allow me to post hyperlink, not sure why: github.com/promach/noc/blob/development/spidergon_top.v#L479

Screenshot from 2020-06-07 09-14-24.png
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
46,916
Helped
13,916
Reputation
28,080
Reaction score
12,562
Trophy points
1,393
Location
Bochum, Germany
Activity points
273,647
The system does not allow me to post hyperlink, not sure why
Setup of the new forum software is still in progress.

"Executing" lines #477f is only one way to set the variable, it's also assigned in #447.
 

promach

Advanced Member level 3
Joined
Feb 22, 2016
Messages
865
Helped
1
Reputation
2
Reaction score
2
Trophy points
18
Activity points
8,451
Why flit_data_output_contains_header[NUM_OF_NODES*NUM_OF_PORTS-1:0] is being optimized to flit_data_output_contains_header[2*NUM_OF_PORTS-1:0] ?


Screenshot from 2020-06-08 00-26-56.png
 

Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top