Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

PSPICE Simulation of a flyback transformer

Status
Not open for further replies.

strape81

Junior Member level 3
Joined
Dec 16, 2011
Messages
25
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,283
Activity points
1,558
Hi everyone,

I have just created a .lib and .olb file of a flyback transformer using the Magnetics Part Editor which is available with orcad (see View attachment trafo4042.zip).

As next step I have made a schematic using this transformer in order to test if it works properly (see flyback_conv.JPG).

I have run a simulation in time domain but the following errors occured, which I cannot understand :

*Analysis directives:
.TRAN 0 1000ns 0
.OPTIONS DIGINITSTATE= 0
.PROBE V(alias(*)) I(alias(*)) W(alias(*)) D(alias(*)) NOISE(alias(*))
.INC "..\SCHEMATIC1.net"

**** INCLUDING SCHEMATIC1.net ****
* source TESTING_TRAFO4042
D_D3 N06013 OUT15V D1N4003
D_D1 N10730 OUT13V ZHCS750/ZTX
X_U1 N00149 N00095 N06013 0 N10730 0 N08144 0 TRAFO4042 PARAMS: NP=24
+ RSP=0.056011 LLP=5.86021E-006 NS1=4 RSS1=0.127423 NS2=4 RSS2=0.00654831 NS3=6
+ RSS3=0.0138977 GAP=0.024055
R_R3 0 OUT19V 1G TC=0,0
V_V2 N00412 0
+PULSE -5 15 0 0 0 10u 20u
R_R4 OUT15V 0 100 TC=0,0
X_M1 N00095 N00412 0 IXFK120N20/IXS
V_V1 N00149 0 127Vdc
C_C3 OUT15V 0 47u
C_C1 OUT13V 0 680u
C_C2 OUT19V 0 680u
D_D2 N08144 OUT19V ZHCS750/ZTX
R_R2 0 OUT13V 1G TC=0,0

**** RESUMING testing_trafo4042.cir ****
.END

ERROR -- Less than 2 connections at node N06013 (The node connected to V_OUT11)
ERROR -- Less than 2 connections at node N10730 (The node connected to V_OUT21)
ERROR -- Less than 2 connections at node N08144 (The node connected to V_OUT31)
ERROR -- Less than 2 connections at node X_U1.V_OUT11
ERROR -- Less than 2 connections at node X_U1.V_OUT21
ERROR -- Less than 2 connections at node X_U1.V_OUT31
ERROR -- Node X_U1.NLS1 is floating
ERROR -- Node X_U1.V_OUT12 is floating
ERROR -- Node X_U1.V_OUT11 is floating
ERROR -- Node X_U1.NLS2 is floating
ERROR -- Node X_U1.V_OUT22 is floating
ERROR -- Node X_U1.V_OUT21 is floating
ERROR -- Node X_U1.NLS3 is floating
ERROR -- Node X_U1.V_OUT32 is floating
ERROR -- Node X_U1.V_OUT31 is floating


Please does anyone have an idea why these errors occur?

For your information:
The pins of the transformer are set to "Passive".
PSPICE Error Guide : View attachment psphlp with error explanations.pdf
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
47,945
Helped
14,144
Reputation
28,547
Reaction score
12,829
Trophy points
1,393
Location
Bochum, Germany
Activity points
278,156
The terminal signal names of the subcircuit don't correspond to the internal used names, e.g. V_OUT11V versus V_OUT11.

Code:
* PSpice Model Editor - Version 16.2.0
* Generated by Magnetic Parts Editor on 21.12.2011
* Trafo 4042-T1
.subckt trafo4042 V_IN1 V_IN2 
+ V_OUT11V V_OUT12V 
+ V_OUT21V V_OUT22V 
+ V_OUT31V V_OUT32V 
+ PARAMS: 
+ Np=24 RSp=0.056011 Llp=5.86021e-006 
+ Ns1=4 RSs1=0.127423 Ns2=4 RSs2=0.00654831 Ns3=6 RSs3=0.0138977 
+ Gap=0.024055
L_LP NLP V_IN2 {Np}
R_RP NRP NLP {RSp}
L_Leak V_IN1 NRP {Llp}
L_LS1 NLS1 V_OUT12 {Ns1}
R_RS1 NLS1 V_OUT11 {RSs1}
L_LS2 NLS2 V_OUT22 {Ns2}
R_RS2 NLS2 V_OUT21 {RSs2}
L_LS3 NLS3 V_OUT32 {Ns3}
R_RS3 NLS3 V_OUT31 {RSs3}
K_K2 L_LP L_LS1 L_LS2 L_LS3 1.0 core_model_K1
.model core_model_K1 AKO:core_model CORE (GAP={Gap})
.model core_model CORE (LEVEL=3 OD=6.19 ID=0 AREA=0.832 GAP=0.024055 Br=1700 Bm=4500 Hc=0.1875)
.ends trafo4042
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top