Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Problems with Spartan Evaluation Board

Status
Not open for further replies.

Lykos1986

Member level 4
Joined
Jan 30, 2006
Messages
69
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,876
spartan which board

I have got the Altium LiveDesign Evaluation Board with Spartan 3 (3S1000).
When I am trying to download a project in to the board with iMPACT the first times I am tring to download the program I have a FAILED and then everything its ok. I don’t know what is going wrong.

In FAILED operation the iMPACTS says
.
.
.
value of MODE pin M0 : 1
value of MODE pin M1 : 0
value of MODE pin M2 : 1
value of CFG_RDY (INIT_B) : 1
DONEIN input from DONE pin : 0
ID_ERROR : 0
RESERVED : 0
RESERVED : 0
INFO:iMPACT:2219 - Status register values:
INFO:iMPACT - 0011 0000 1011 0000 0000 0000 0000 0000
INFO:iMPACT:579 - '1': Completed downloading bit file to device.
INFO:iMPACT:580 - '1':Checking done pin ....done.
'1': Programming terminated, Done did not go high.
PROGRESS_END - End Operation.
Elapsed time = 13 sec.




In Program Done operation the iMPACT says
.
.
.
value of MODE pin M0 : 1
value of MODE pin M1 : 0
value of MODE pin M2 : 1
value of CFG_RDY (INIT_B) : 1
DONEIN input from DONE pin : 1
ID_ERROR : 0
RESERVED : 0
RESERVED : 0
INFO:iMPACT:2219 - Status register values:
INFO:iMPACT - 0011 0111 1011 1000 0000 0000 0000 0000
INFO:iMPACT:579 - '1': Completed downloading bit file to device.
INFO:iMPACT:580 - '1':Checking done pin ....done.
'1': Programmed successfully.
PROGRESS_END - End Operation.
Elapsed time = 13 sec.
 

EDALIST

Full Member level 2
Joined
Nov 27, 2004
Messages
131
Helped
12
Reputation
24
Reaction score
0
Trophy points
1,296
Activity points
992
impact spartan board done did not go high problem

what version of IMPACT are you using ?

try to upgrade for newer versions.

also try to use a xilinx cable instead. if you can put a hand on the latest USB
platform Cable You Can Achieve Real High Speeds

altium built there own cable, and it look a bit amature.
 

Lykos1986

Member level 4
Joined
Jan 30, 2006
Messages
69
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,876
spartan evaluators

I use the Xilinx WebPack 8.1.03i
 

shankarmit

Full Member level 3
Joined
Jun 22, 2005
Messages
186
Helped
30
Reputation
60
Reaction score
22
Trophy points
1,298
Location
India
Activity points
2,858
done did not go high spartan

every time you star impact

u must do cable check up and cable established message will come then u start with downloading the bits.
may be this may be the cause.


Regards
Shankar
 

Lykos1986

Member level 4
Joined
Jan 30, 2006
Messages
69
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,876
donein input from done pin spartan

I always getting the cable established message but then… nothing. I have to press the download 3 times to get a Programmed successfully message.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top