Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Problems with LCD 16x2 connection

Status
Not open for further replies.

Linspire

Full Member level 5
Joined
Sep 1, 2011
Messages
303
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,298
Location
M'sia
Activity points
3,279
Guys,
I have desolder working LCD 16x2 from other circuit, however,when I directly connect with correct connection, it does not working.
Should I really add resistor 100ohm to Vdd ?

How about this description ?
Note.PNG



Regards
Linspire
 

ckshivaram

Advanced Member level 5
Joined
Apr 21, 2008
Messages
5,070
Helped
2,149
Reputation
4,304
Reaction score
2,089
Trophy points
1,393
Location
villingen (Germany) / Bangalore
Activity points
30,086
Re: LCD 16x2 MODEL:162A

the explaination is correct, i too had faced this problem, send the 0x30 command 3 times when you initialize the lcd in routine. adding 100 Ohm is optional.
 

Linspire

Full Member level 5
Joined
Sep 1, 2011
Messages
303
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,298
Location
M'sia
Activity points
3,279
Re: LCD 16x2 MODEL:162A

Any idea how to sent the command in my mikroC ?
My LCD right now doesn't work at all even show whole black dot by directly connect to the power supply.


Linspire
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top