Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Problems with HC-05 bluetooth module

reza147

Member level 1
Joined
May 9, 2013
Messages
33
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,288
Activity points
1,584
Hello
Problems with HC-05 bluetooth module.
When i turn on the module a led in hc-05 be blinking fast. This indicates that the module is in DATA mode. In this case, when I search the phone with Bluetooth, it correctly finds the Bluetooth module named HC-05.
When i hold Key_module (or connected EN_pin to VCC_pin) then conncted power to module, Now the led on the module will blink at the interval of 2 seconds. That means it has entered the AT mode?! (then i release Key_module or EN_pin)
But when i send "AT" command, module no respons. (i test with VCC=3.3v or 5v/ with 1200 to 230400 boud rate). Also I search the phone with Bluetooth,but not finds the Bluetooth module.

Having multiple bluetooth modules with the same name can be confusing. i attach pic of my module. Please tell if anyone can help .

Rx pin of the Bluetooth module to Tx pin of USB to TTL converter, and Tx pin of Bluetooth to Rx pin of converter. Also connect their ground to power_GND. (connect their Vcc to 3.3v or 5v)
 

Attachments

  • b.png
    b.png
    66.3 KB · Views: 8
  • 61b26TAcCoL._AC_SL1500_.jpg
    61b26TAcCoL._AC_SL1500_.jpg
    48.9 KB · Views: 8

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
48,396
Helped
14,251
Reputation
28,763
Reaction score
12,937
Trophy points
1,393
Location
Bochum, Germany
Activity points
280,075
HC-05 AT command interface is a bit tricky.
- AT interface is case sensitive
- commands must be terminated with <CR><LF>, most terminals don't provide it. I'm usually typing CTRL-M + CTRL-J instead of Enter key.
- Baud rate is 38k4
--- Updated ---

Module name can be programmed in AT mode
 
Last edited:

reza147

Member level 1
Joined
May 9, 2013
Messages
33
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,288
Activity points
1,584
Hello
I respect the buadrate and case sensitive and hardware. (I think)
But i could not get the"OK" from HC-05.[ when i send "AT" command, module no respons.]

Please let me know if anyone has worked and received an answer. (Exactly with the same module that I sent in the photo)
thanks
 

KlausST

Super Moderator
Staff member
Joined
Apr 17, 2014
Messages
19,717
Helped
4,343
Reputation
8,695
Reaction score
4,304
Trophy points
1,393
Activity points
130,522
Hi,

Can you show a photo of your wiring (including HC-05 module and USB converter)

Klaus
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
48,396
Helped
14,251
Reputation
28,763
Reaction score
12,937
Trophy points
1,393
Location
Bochum, Germany
Activity points
280,075
Additional information, I have the "EN" pin (driving pin 34 of the original HC-05 module) bridged to VCC, thus 38k4 baudrate is selected. Corresponds to holding the button during power-up.

1623402797591.png
 

reza147

Member level 1
Joined
May 9, 2013
Messages
33
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,288
Activity points
1,584
HC-05 AT command interface is a bit tricky.
- AT interface is case sensitive
- commands must be terminated with <CR><LF>, most terminals don't provide it. I'm usually typing CTRL-M + CTRL-J instead of Enter key.
- Baud rate is 38k4
--- Updated ---

Module name can be programmed in AT mode
Hi
how i to send "CTRL-M + CTRL-J instead of Enter key" on the "Tera Term".
--- Updated ---

Additional information, I have the "EN" pin (driving pin 34 of the original HC-05 module) bridged to VCC, thus 38k4 baudrate is selected. Corresponds to holding the button during power-up.

View attachment 170077
Hi.
When i hold Key_module (or connected EN_pin to VCC_pin) then conncted power to module, Now the led on the module will blink at the interval of 2 seconds. I search the phone with Bluetooth,but not finds the Bluetooth module.
For this case, can your module be detected by the phone?
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
48,396
Helped
14,251
Reputation
28,763
Reaction score
12,937
Trophy points
1,393
Location
Bochum, Germany
Activity points
280,075
Hold the CTRL key and press "M" and "J".

I believe, you can also set up Tera Term to send CR+LF in the terminal settings.

Please notice that I'm using Putty rather than Tera Term, thus I'm not completely sure about the behaviour.
 
Last edited:

reza147

Member level 1
Joined
May 9, 2013
Messages
33
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,288
Activity points
1,584
Hold the CTRL key and press "M" and "J".

I believe, you can also set up Tera Term to send CR+LF in the terminal settings.
Yes, thank you. But I still do not receive "OK".
Since these modules are similar, is it possible that the HC-06 type was assembled incorrectly?
If it is HC-06 type, does it not respond to AT commands?
 

KlausST

Super Moderator
Staff member
Joined
Apr 17, 2014
Messages
19,717
Helped
4,343
Reputation
8,695
Reaction score
4,304
Trophy points
1,393
Activity points
130,522
Hi,

We currently have nothing "objective" to validate. We see your text, but this is "what you expect".

If you want us to validate something, then post photos (small file zize) of the complete wiring and screenshots.

Klaus
 

LaTeX Commands Quick-Menu:

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top