Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Problem with manual routing in Orcad PCB Editor

Status
Not open for further replies.

hobbss

Member level 2
Joined
Oct 18, 2010
Messages
49
Helped
20
Reputation
40
Reaction score
19
Trophy points
1,288
Activity points
1,858
I have a board that is about 50% routed (manually). Suddenly, I can no longer route "normally." If I am in "Add Connect" mode, and click on a pin, the net does not snap to the connection point. The only way to get a net to start on a pin is to first select the pin (while in idle mode), and then begin the "add connect" command. Then, when I get to the other end of the signal (i.e., another pin), the only way to get the etch to terminate properly on the other pin is to right click, select "snap to," and then select pin. It seems like this must be some kind of grid issue, but I can't figure it out. I can't even go back to previously routed components and add new etches. It is almost as if the router is on a different grid setting then everything else, but the grid options are still the same (25 x / 25 y) for all etch. Has anyone seen this, and if so, how did they get around it? If there is a third option (after starting over and doing the multiple click routine described above) for the >200 traces left on the board, I would rather do it...
 

hobbss

Member level 2
Joined
Oct 18, 2010
Messages
49
Helped
20
Reputation
40
Reaction score
19
Trophy points
1,288
Activity points
1,858
For anyone who ever has the same problem as me (I hate it when I find a thread somewhere where someone had the exact same problem as me and never posted the eventual solution):

It was a picnic (Problem In Chair, Not In Computer). The underlying cause of my problem was that the Find Filter is not universal, and it does have retention memory. Meaning: at some point I must have turned "All Off" while in Add Connect Mode without realizing the command was still active. I then exited the command (went to Idle state), where everything was already off. I then must have proceeded to turn "All On" in that state, but NOT in the Add Connect Mode. Therefore, when I re-entered Add Connect Mode, everything was still disabled in the find filter. This was why I could select pins in idle mode, then enter Add Connect Mode, and route from there.

Moral of the story: each command state has its own settings for the Find Filter, and they remember those settings even when you exit the command state. To fix my problem, all I had to do was re-enter Add Connect Mode, and select "Find All" in the find filter settings.
 
Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top