Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Problem with D2XX as it can't open jtag

Status
Not open for further replies.

TrriKri

Newbie level 4
Joined
Jun 10, 2008
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,328
I'm writing an application which is supposed to communicate with a JTAG from Amontec using the d2xx library for Linux. The drivers for the device are installed. The key is recognized by the computer, since it's listed in the proc file /proc/bus/usb/devices. When I run my application, first the VID/PID are changed with FT_SetVIDPID to the appropriate values. Then the number of devices are fetched with FT_ListDevices(&numDevs, NULL, FT_LIST_NUMBER_ONLY), and the value of numDevs then becomes 2 (why 2? There's only one device in the proc file with that VID/PID combination).

After that I run into problems. When I try to fetch information about the devices found, using FT_ListDevices, it returns 18 (FT_OTHER_ERROR), both when trying to fetch serial number and description, and both when trying to fetch it one by one and all at once.

Then I tried to open the device by serial number (since the proc file contains that info), and then by description, with FT_OpenEx, but both of those tries returned 2 (FT_DEVICE_NOT_FOUND). Then I tried to open by index using FT_Open. Indexes 0 and 1 returned 3 (FT_DEVICE_NOT_OPENED), while indexes > 1 also returned 2.

If anyone can tell me why I run into so much trouble I would be very thankful. The JTAGkey is a normal FT2232 JTAGkey from Amontec. Thanks in advance!
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
47,996
Helped
14,151
Reputation
28,561
Reaction score
12,842
Trophy points
1,393
Location
Bochum, Germany
Activity points
278,365
error: ft_listdevices(18)

Resending your previous post is a kind of unwanted cross-posting, see rules & points.

Did you notice the FAQ remark, why FT_DEVICE_NOT_OPENED may occur? I think, it may be due to VCP driver also in your case.

FT2232 has two channels, so I would be surprized, if the driver doesn't install two devices.
 

TrriKri

Newbie level 4
Joined
Jun 10, 2008
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,328
ftdi d2xx 0 numdevs

Sorry for the cross-posting, my previous thread seemed to get to few visitors because of it's badly chosen name.

But, he, I found the reason for the error - I wasn't logged in as root. Maybe there should be one more error state, FT_PERMISSION_DENIED or something.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top