Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

problem when adding stripe

Status
Not open for further replies.

scscsc

Junior Member level 2
Joined
Apr 20, 2010
Messages
21
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,464
problem when adding stripe :antenna segment

Hi everyone,

I have a problem when adding stripes in my design. I want to add four vertical stripes. The first one works. The second and third one are shorter than the value I set. The fourth one is cut into two segments. There are warnings like this (ex. fourth stripe).
The power planner cannot find target for the antenna segment at 19.30 48.10. Please use sroute to connect them.
The power planner cannot find target for the antenna segment at 13.30 55.40. Please use sroute to connect them.

It seems that the placement of my modules affects the stripes. Anyone has an idea of the reason? can I add stripes first before the placement?

Here is my script for stripes adding
addStripe -block_ring_top_layer_limit M7 -max_same_layer_jog_length 6 -padcore_ring_bottom_layer_limit M5 -number_of_sets 1 -stacked_via_top_layer AP -padcore_ring_top_layer_limit M7 -spacing 2 -merge_stripes_value 2.5 -layer M6 -block_ring_bottom_layer_limit M5 -width 6 -area {135.4 135.2 129.4 0} -nets gnd -stacked_via_bottom_layer M1

addStripe -block_ring_top_layer_limit M7 -max_same_layer_jog_length 6 -padcore_ring_bottom_layer_limit M5 -number_of_sets 1 -stacked_via_top_layer AP -padcore_ring_top_layer_limit M7 -spacing 2 -merge_stripes_value 2.5 -layer M6 -block_ring_bottom_layer_limit M5 -width 6 -area {96.6 135.2 90.6 0} -nets vdd -stacked_via_bottom_layer M1

addStripe -block_ring_top_layer_limit M7 -max_same_layer_jog_length 6 -padcore_ring_bottom_layer_limit M5 -number_of_sets 1 -stacked_via_top_layer AP -padcore_ring_top_layer_limit M7 -spacing 2 -merge_stripes_value 2.5 -layer M6 -block_ring_bottom_layer_limit M5 -width 6 -area {53.2 135.2 47.2 0} -nets gnd -stacked_via_bottom_layer M1

addStripe -block_ring_top_layer_limit M7 -max_same_layer_jog_length 6 -padcore_ring_bottom_layer_limit M5 -number_of_sets 1 -stacked_via_top_layer AP -padcore_ring_top_layer_limit M7 -spacing 2 -merge_stripes_value 2.5 -layer M6 -block_ring_bottom_layer_limit M5 -width 6 -area {19.3 135.2 13.3 0} -nets vdd -stacked_via_bottom_layer M1
 

vimalraj205

Member level 3
Joined
Oct 11, 2011
Messages
65
Helped
16
Reputation
32
Reaction score
14
Trophy points
1,288
Activity points
1,670
Re: problem when adding stripe :antenna segment

Hai friend

you must first finish your power planning first and then go for the placement

if you are facing such problems you can try those in the GUI window and even if you cant solve this can you represent it in a pictorial view
 

vijayR15

Full Member level 3
Joined
Dec 10, 2011
Messages
173
Helped
69
Reputation
136
Reaction score
63
Trophy points
1,308
Activity points
2,381
Hai scscs,

Try with the below script it will draw four stripes..

addStripe -block_ring_top_layer_limit M7 -max_same_layer_jog_length 6 -padcore_ring_bottom_layer_limit M5 -set_to_set_distance 30 -stacked_via_top_layer AP -padcore_ring_top_layer_limit M7 -spacing 2 -xleft_offset 25 -merge_stripes_value 2.5 -layer M6 -block_ring_bottom_layer_limit M5 -width 6 -nets vdd -stacked_via_bottom_layer M1

adjust set to set distance and xleft_offset value to vary stripe location..

The reason for your script not working is may be with the size (i.e) area value may be higher in the scipts you specified. Have you tried with varying the area value.
 
  • Like
Reactions: scscsc

    scscsc

    Points: 2
    Helpful Answer Positive Rating

scscsc

Junior Member level 2
Joined
Apr 20, 2010
Messages
21
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,464
Re: problem when adding stripe :antenna segment

Hi vimalraj205,

when I say placement I mean the placement of IP instances not the standard cells. Anyway, thank you for your suggestion.

- - - Updated - - -

- - - Updated - - -

- - - Updated - - -

Thank you vijayR15!
Hai scscs,

Try with the below script it will draw four stripes..

addStripe -block_ring_top_layer_limit M7 -max_same_layer_jog_length 6 -padcore_ring_bottom_layer_limit M5 -set_to_set_distance 30 -stacked_via_top_layer AP -padcore_ring_top_layer_limit M7 -spacing 2 -xleft_offset 25 -merge_stripes_value 2.5 -layer M6 -block_ring_bottom_layer_limit M5 -width 6 -nets vdd -stacked_via_bottom_layer M1

adjust set to set distance and xleft_offset value to vary stripe location..

The reason for your script not working is may be with the size (i.e) area value may be higher in the scipts you specified. Have you tried with varying the area value.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top