Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] Problem: transistor switch

Status
Not open for further replies.

omaroski

Newbie level 5
Joined
Apr 16, 2011
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,352
Hello everybody,

I'm using a IRF530A mosfet transistor for switching and controlling a solenoid.

Connection is: from psu V+ to solenoid lead and other solenoid lead to drain, source to psu ground.

The problem is that, even when not using the gate to control the transistor, the IRF530A goes in saturation and runs very hot after few seconds.

Voltage from psu is 24V, current in the circuit is 2A, solenoid's resistance is around 15ohm. IRF 530A has a MAX values of Vds 100V and Id 16A in the datasheet.

Connections are ok and checked several times, i used also another psu and the solenoid many times before.

With a 2N3055 everything is ok and when i was using IRF530N before IRF530A everything was ok too.

I have a stock of 20 IF530A just purchased from rs-components, i tried 6 of them and they all have the same problem. Is it possible that they are defectives?


What else might be?

Thank you very much
Omar
 

omaroski

Newbie level 5
Joined
Apr 16, 2011
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,352
No, is that the problem? What resistor should se used?

---------- Post added at 14:49 ---------- Previous post was at 14:45 ----------

Yes, that was, my ignorance, thank you very much!
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top