Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Power-up contrast stains problem with embedded winstar LCD

Status
Not open for further replies.

ulmus

Newbie level 1
Joined
Nov 6, 2013
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
13
Hi!

Please, help me solving this problem:
I have LCD type of WX320240D-TFH-V#I (graphics 320x240 pixs, RA8835 ctrlr)and have problem with contrast
stains which appear just after I power-up LCD
and dissapear slowly after few seconds. It happens when i turn it on
after few hours. Then this efect is dissapearing if i turn device off and
on,
but if i wait few hours and turn the device on, i can see again those
contrast blur/stains for few seconds, and again: if i turn on and off it
doesnt happen.

Shortly: after long power off time, when i, for the first time since long time, turn it
on, i can see those contrast stains for once. Next power ons dont do
that... i have to wait few hours.

I did, i think, all i can... checked it on lcd manufactured 2years ago and
the newest ones (D version) and it is still the same. I chacked power
supply and it is good 3,3V.
Circuit is as in documentation (just variable resistor to regulate
contrast).

Everything works great but those few seconds with contrast stains after loooong power off of my system.

Do you know anything about this effect or similar and have something to avoid that?

I would be very grateful for any help!!!

Thanks in advance!
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top