Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Power-on reset problems with ATMega164

Status
Not open for further replies.

oyvdahl

Member level 5
Joined
Apr 26, 2010
Messages
86
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Oslo, Norway
Activity points
1,810
I have some problems with the reset of ATMega164.

I read that it was suppose to have built-in power-on reset, but I cannot make it work.

When I power up, sometimes the controller is reset and everything works fine, while other times the controller is not reset and nothing works.

I tried putting on a RC delay on the reset, with up to 10 ms of delay, still it only works from time to time.

But when I take a ground wire and manually put it on the reset pin on startup, the remove it. It always works.

Does anyone have any suggestions to what I could to to make the controller reset every time?

Best Regards
Oyvind
 

oyvdahl

Member level 5
Joined
Apr 26, 2010
Messages
86
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Oslo, Norway
Activity points
1,810
Ok, I figured it out. I used a 0.47uF cap, and it stored the energi so that the circuit did not work then I turned the power off, then on again after a few seconds. That's why you shouldn't use RC for power-on reset i guess.
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top