Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

PICALL/P16PRO programmer

Status
Not open for further replies.

yoku

Junior Member level 1
Joined
Mar 19, 2002
Messages
15
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
55
picall

Does any one has tested PICALL/P16PRO programming software version .13d from www.picallw.com for 18F series PIC's

Its giving me DEVICE NOT BLAKED ERROR.
 

Mr.Cool

Advanced Member level 2
Joined
Jun 20, 2001
Messages
664
Helped
87
Reputation
178
Reaction score
60
Trophy points
1,308
Activity points
7,113
picall programmer

ahhh! so frusturating. i have had this exact error for 2 days now.

i am trying to program 16F84. i used microstudio (with pic basic pro v2.42) to compile the pbp sample program "Blink.bas". it compiles fine and produces a Hex file. i am using Picall windows version 0.13c (latest version as of oct 9th 02).
the programmer i am using is the P16PRO40, it has the part #74Ls05. according to some documents and the p16pro settings menu, i should select "kit 96" as the default hardware setup options within picall.

so i do this. within microstudio i select "compile and program".... i watch the lights on the programmer but the red program LED does not come on. then the picall program window pops up with 3FFF in all the data addresses... hmm... what happened? dunno. did anythikng program? i doubt it.

so i hit the "verify" button and i get:

Verify Error:
Program: address=0007 buffer=3FFF device=3F00

hmmm......
so then i say "forget microstudio, i'll just manually download the hex file from within picall". so, i click on program open "blink.hex". now the memorry address is filled with things other than 3FFF for the first few addresses.. ok, so it looks like i must have successfully opened blink.hex.
now i press ERASE. i watch the program LED on the programmer and it flashes RED. ok, so i guess it erased something. now i press BLANK CHECK. says "device is not blank"... but how could this be??

so i move on, and manually hit the PROGRAM button. the red LED on the programmer lights up... so it must be programming. then i get a window "device is not blank". i guess it wouldn't be blank since i just programmed something to it!

so to verify my successful program i select "VERIFY". now i get error

Verify Error:
Program: address=0000 buffer=2828 device=3FFF

anyone know what's going on here???

Mr.Cool
 

Mr.Cool

Advanced Member level 2
Joined
Jun 20, 2001
Messages
664
Helped
87
Reputation
178
Reaction score
60
Trophy points
1,308
Activity points
7,113
picall software

oh yeah, so i check my program by clicking on "READ" and then the memory locations as indicated within picall changes to a bunch of 3FFF and 3F00's. every time i hit the READ button the randomly placed 3FFF and 3F00 changes.. the only bytes shown in the memory addresses is either 3FFF or 3F00. and it may change (randomly) every time i hit the READ button , but still always either a 3FFF or 3F00

Mr.Cool
 

dabi

Member level 1
Joined
Jul 9, 2002
Messages
34
Helped
3
Reputation
6
Reaction score
1
Trophy points
1,288
Activity points
142
p16pro

Change Pro Delay from 1100 to 2000 or bigger.
It is all ok!
 

Mr.Cool

Advanced Member level 2
Joined
Jun 20, 2001
Messages
664
Helped
87
Reputation
178
Reaction score
60
Trophy points
1,308
Activity points
7,113
picall software download

sorry, i mean i am using picall version 0.013d (it says "c" on the web site but when you press the Help button in the software it says "d").

i have tried raising the delay to 2000. Also, you *must* remove the "Auto Adjust" check-mark.

now it works perfectly. THANK YOU!!!

i have spent 2-3 days getting this system working.

thanks everyone that has helped (i got a few private messages too) :D

Mr.Cool
 

yoku

Junior Member level 1
Joined
Mar 19, 2002
Messages
15
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
55
p16pro programming led

Thanks a lot. My problem is solved too by increasing delay and removing auto adjust delay option.
 

Mr.Cool

Advanced Member level 2
Joined
Jun 20, 2001
Messages
664
Helped
87
Reputation
178
Reaction score
60
Trophy points
1,308
Activity points
7,113
picall firmware

has anyone successfully used a P16PRO to program a PIC 16F877A ???

if so please post how you did this.

i can not get it to work.. it programs perfectly when compiled for a 16F84. then i re-compile for 16F877A and change the picall software (regged version) to 16F877A and it don't work.

Mr.Cool
 

S

sick_man

Guest
picall download

did you change the inc file it uses to pic877a

as i say there may be no inc file for this in your compiler

check that it produces a pic 877a compatable hex file

the a version inc files come with the latest mplab

the system to use is this

cross compile as normal with microcode studio

then compile the asm to hex with mplab

then program using 877 option

paying attention to the header to make sure you program the correct fuses for this varient.... 877a


as the fuses are all that matters


so.. again you need to add this too the ini

you can descover these by looking at the data sheet

but as other members point out it may just be the way you compile and program

the pic all you need the latest version

check for support before just porting the hex straight to the chip

or use mplab latest version to compile to hex first it will have the correct inc files
 

kima

Junior Member level 3
Joined
Jul 25, 2002
Messages
28
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
161
what should i check in picall programmer

just use pic16f877 and problem solved!!!
 

Mr.Cool

Advanced Member level 2
Joined
Jun 20, 2001
Messages
664
Helped
87
Reputation
178
Reaction score
60
Trophy points
1,308
Activity points
7,113
p16pro download

my setup is
editor: Microcode Studio
compiler: Pic Basic Pro 2.42
programmer: PICall 0.013d

pic basic pro has support for the 877A. so when i select 877A within microstudio i assume that it compiles the software correctly with proper fuses.

in fact, i opened my compiled file (blink.asm) and it reads:

; PicBasic Pro Compiler 2.42, (c) 1998, 2002 microEngineering Labs, Inc. All Rights Reserved.
PM_USED EQU 1

INCLUDE "16F877A.INC"

so i must believe that it is not a compiler error.

Mr.Cool
 

xpembedded

Newbie level 6
Joined
May 27, 2004
Messages
14
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
90
picall

i am having this problem : program verify error when programming

16f84a chip


can anyone help me?


try turning off the auto adjust also no use
 

hassana

Newbie level 5
Joined
Jan 16, 2005
Messages
9
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
70
p16pro what to use in place of 74ls05

Did you have the hex program for 16C62 to pic all programmer
 

justmarc

Newbie level 1
Joined
Feb 26, 2005
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,296
18f blink.asm

Hi all, I just bought a Picall programmer that has the latest firmware. I am using the Latest V0.16 Picall software. I bought the programmer so that I could program PIC16c621A-04/p and PIC12c509A-04/p devices and have been succesfull with the PIC16c621A-04/p. When I try to program a PIC12c509A, a warning comes up saying "There is no device in the ZIF socket". After I get that warning I can then emmidiately choose PIC16c621A-04/p and program it with no problem.

I soldered a 40 pin ZIF socket on the board and am inserting the chip according to the diagram.

I am running Windows XP

Any ideas will trully be appreciated........Big time!

Marc
 

compvis

Newbie level 2
Joined
Jan 30, 2007
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,289
p16pro programer

Hello justmarc,

Could you share me pic16c62 firmware ?

Am in Vietnam and i couldn't find how to buy it

My mail is: comp_vis@yahoo.com

Thanks you !

Best regard,

Bye.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top