Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Pic assembly problem with BTFSS command

Status
Not open for further replies.

PlatinumT

Member level 3
Joined
Sep 15, 2002
Messages
58
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Location
Arkansas
Activity points
407
Pic assembly problem

sorry this might be lame but I just can't figure this out. I'm trying to learn Pic assembly right now and am going threw the EPE Pic Tutorial v2. I am simulating in Proteus 5.2 sp7 and I think Im getting stuck in LOOP2 because the BTFSS command never satisfies. If someone could help I would greatly appreciate it. The asm file is attached.

Thanks
 

Elavionic

Member level 5
Joined
Apr 6, 2002
Messages
87
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,288
Location
Portugal
Activity points
1,011
I look at your code and don´t find nothing wrong. At the 8th cycle carry bit will be one and jumps to loop1, until them it stays on loop2. You can try to run your code in MPLAB, step by step and check if it is correct. Sorry but i don't have MPLAB installed, right now, so i can't check it for you.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top