Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Parameter sweep in ADS

Status
Not open for further replies.

Gigan

Member level 1
Joined
Feb 26, 2006
Messages
41
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
1,596
I am trying to get s-parameters of simple LC-filter located at the micro-strip substrate while sweeping the length of the central strip.

Photo Nr1 shows the circuit: just two ideal L & C components are connected in series with short MLIN and central strip. The length of MLIN is variable (VAR=L).
For single values of the length (for example, L =10mil and L= 90mil) separate results look good (see Photo 2).

But the Sweep results from L = 10 mil to 90mil with two (for example) steps look "dramatic" (are shown together in Photo3).

Could some one explain why it goes wrong?
 

Attachments

  • Photo Nr1 Sweep Setup.jpg
    Photo Nr1 Sweep Setup.jpg
    193.2 KB · Views: 24
  • Photo Nr2  MLIN_10mil_and_90mil.jpg
    Photo Nr2 MLIN_10mil_and_90mil.jpg
    119.6 KB · Views: 14
  • Photo Nr3 Sweep.jpg
    Photo Nr3 Sweep.jpg
    123.8 KB · Views: 16

volker@muehlhaus

Advanced Member level 5
Joined
Apr 11, 2014
Messages
2,603
Helped
1,003
Reputation
2,010
Reaction score
996
Trophy points
1,393
Activity points
16,720
You are sweeping from 10 to 90 units (m oder inches), not 10 to 90 mil.
Set the unit in the MLIN element parameter, so that L=L mil.
 
  • Like
Reactions: Gigan

    Gigan

    Points: 2
    Helpful Answer Positive Rating

Gigan

Member level 1
Joined
Feb 26, 2006
Messages
41
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
1,596
You are sweeping from 10 to 90 units (m oder inches), not 10 to 90 mil.
Set the unit in the MLIN element parameter, so that L=L mil.

Yes, it works, Thank you!

- - - Updated - - -

You are sweeping from 10 to 90 units (m oder inches), not 10 to 90 mil.
Set the unit in the MLIN element parameter, so that L=L mil.

Hi Volker,
The curves for several sweep-values coincide in general for this filter, they are very close...
only value of resonance-minimums for S11 is changing (and max for S21). On the graph very difficult to understand, which curve correspond to definite L...

Are there ways to manage those curves in graph, to separate them and/or see which curve correspond to definite value of L (sweep parameter)?
 

Attachments

  • Sweep_Results.jpg
    Sweep_Results.jpg
    146.3 KB · Views: 10
Last edited:

Gigan

Member level 1
Joined
Feb 26, 2006
Messages
41
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
1,596
Simulation was good with several ports on the circuit.
When I am adding more pins an error comes:
"
--- ERROR ---------------------------------------------------------------------

Pin "P18" on mask 2 is not positioned on the
edge of a slot. Magnetic pins are only supported
on the edge of slots. This setup is invalid. "
Can I put few ports on one strip?

could some one please explain?
 

Attachments

  • Port18. etc.jpg
    Port18. etc.jpg
    306 KB · Views: 11

Gigan

Member level 1
Joined
Feb 26, 2006
Messages
41
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
1,596
It was simple: some ports were assigned to wrong layer...
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top