Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

PAE of Class E PA (issue with simulation)

Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
Hi,

I had designed a CMOS Power Amplifier using two stage class E topology. May I know why my PAE simulation result didn't have saturation point?
When I tried to check the transistor work or not by simulating dc analysis, but the IV graph comes out is blank. I also tried to run dc analysis on another simple schematic, which has only one transistor, the IV graph still blank.

May I know what happen for my PAE and IV graph?

Hope any experts can give some advices . Thanks in advance.
 

Attachments


vfone

Advanced Member level 5
Joined
Oct 10, 2001
Messages
5,139
Helped
1,526
Reputation
3,053
Reaction score
1,127
Trophy points
1,393
Activity points
32,518
The PAE simulation didn't get the saturation point because it has not reach the saturation point (yet).
To achieve the saturation point you have to increase gradually the Pin more than is shown in the plot (greater than -10dBm).
 

BigBoss

Advanced Member level 5
Joined
Nov 17, 2001
Messages
4,873
Helped
1,480
Reputation
2,958
Reaction score
1,320
Trophy points
1,393
Location
Turkey
Activity points
29,375
Either
-Your Circuit Configuration is wrong
or
-You drive the circuit with very low level that is not sufficient to drive Class-E amplifier.
Post your circuit schematic..
 

Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
The PAE simulation didn't get the saturation point because it has not reach the saturation point (yet).
To achieve the saturation point you have to increase gradually the Pin more than is shown in the plot (greater than -10dBm).
The Pin range I set up to 20dBm but it just show until -10dBm.
 

vfone

Advanced Member level 5
Joined
Oct 10, 2001
Messages
5,139
Helped
1,526
Reputation
3,053
Reaction score
1,127
Trophy points
1,393
Activity points
32,518
Show the plot for Pin greater than -10dBm (up to +20dBm as you said).
Depending by the output power of the PA its possible that not even for Pin=+20dBm to not reach the saturation. For example a 100W PA (+50dBm) for sure will not saturate at Pin=20dBm
 

Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
Either
-Your Circuit Configuration is wrong
or
-You drive the circuit with very low level that is not sufficient to drive Class-E amplifier.
Post your circuit schematic..
 

Attachments


Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
Show the plot for Pin greater than -10dBm (up to +20dBm as you said).
Depending by the output power of the PA its possible that not even for Pin=+20dBm to not reach the saturation. For example a 100W PA (+50dBm) for sure will not saturate at Pin=20dBm
This one i set Pin from -30dBm to +20dBm
 

Attachments


vfone

Advanced Member level 5
Joined
Oct 10, 2001
Messages
5,139
Helped
1,526
Reputation
3,053
Reaction score
1,127
Trophy points
1,393
Activity points
32,518
The plot you posted is not stopping at Pin=+20dB but is stopping at Pin= -5dBm..
 

Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
The plot you posted is not stopping at Pin=+20dB but is stopping at Pin= -5dBm..
ya.. that's my problem facing right now. Even though I set until +20dBm, the simulation result came out around -5 to -10dBm only
 

BigBoss

Advanced Member level 5
Joined
Nov 17, 2001
Messages
4,873
Helped
1,480
Reputation
2,958
Reaction score
1,320
Trophy points
1,393
Location
Turkey
Activity points
29,375
Make a transisent analysis and check the voltage and current waveforms at each node. I think your circuit does is not healthy..
 

Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
Make a transisent analysis and check the voltage and current waveforms at each node. I think your circuit does is not healthy..
I had ran transient analysis at each node, but the result came out is blank. May I know which part got problem? Can you advise me please? Thanks
 

BigBoss

Advanced Member level 5
Joined
Nov 17, 2001
Messages
4,873
Helped
1,480
Reputation
2,958
Reaction score
1,320
Trophy points
1,393
Location
Turkey
Activity points
29,375
I had ran transient analysis at each node, but the result came out is blank. May I know which part got problem? Can you advise me please? Thanks
Check the node voltages and branch currents step by step and follow the signal. That's solely solution.
Where the signal disappears? Operating Points ? Currents are healthy ?? Check them all like a repairman..
 

Xxy

Newbie level 5
Joined
Oct 22, 2020
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
50
Make a transisent analysis and check the voltage and current waveforms at each node. I think your circuit does is not healthy..
I had ran transient analysis at each node, but the result came out is blank. May I know which part got problem? Can you advise me please? Thanks
Check the node voltages and branch currents step by step and follow the signal. That's solely solution.
Where the signal disappears? Operating Points ? Currents are healthy ?? Check them all like a repairman..
Can you provide the link or manual regarding steps to check the node voltages and branch currents?
 

Fhasan

Newbie level 6
Joined
Oct 3, 2010
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,377
Perhaps your software might be corrupted.
 

Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top