Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] Modelsim Code Coverage: Generate-blocks are automatically included

Status
Not open for further replies.

Don Quijote

Newbie
Joined
Jun 16, 2020
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
21
Hello everyone,

I use Modelsim DE-64 2019.3.

I have a complex design with lots of "generate"-blocks in it. When I run code coverage and only include selected modules, every "generate"-block is analyzed even though none of the selected modules is inside the "generate"-block. This corrupts the total coverage (and other results of the analysis).

Long ago, there used to be a command for the modelsim.ini-file called "-nocovergenerate", but it doesn't exist anymore.

What can I do to get Modelsim to ignore the "generate"-blocks?

Thanks for you help!
 

Don Quijote

Newbie
Joined
Jun 16, 2020
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
21
I got confused with Modelsim's results display. I looked at the "Assertion" column.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search


Welcome to EDABoard.com

Sponsor

Sponsor

Design Fast


×
Top