Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Mahindra Inverter continuous beep sound and all led glowing except battery indicator

Joined
May 10, 2022
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
36
I have my Mahindra powerol inverter 1000VA making continuous beep and all led glow except battery indicator on inverter panel . should I change the PIC16F72 or any resistor ?

Kindly help me

Thanks
 

wwfeldman

Advanced Member level 3
Joined
Jan 25, 2019
Messages
985
Helped
216
Reputation
431
Reaction score
256
Trophy points
63
Activity points
7,357
if you unplug everything from the output side of the UPS, the "overload" will (presumably) go out
that should give the UPS a chance to charge the battery
and (presumably) the beeping will stop

i think the beeping is related to the overload and/or the low battery

is the input side connected to the appropriate power source?
if there is an input voltage switch, is it set to the correct supply voltage?
(i blew up an HP ARB, yes, it was HP in those days, not Agilent, by plugging it into a 220V Source, with the switch set to 110V)

as noted before, what does the owner's manual say about the beeping and the LEDs?
what does the owners manual say about the first charging, when you take it out of the box to use it?

how old is it?
how old is the battery?
did you follow all of the steps to set up the UPS?
 
Joined
May 10, 2022
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
36
if you unplug everything from the output side of the UPS, the "overload" will (presumably) go out
that should give the UPS a chance to charge the battery

and (presumably) the beeping will stop
There is no change if I unplug from inverter output still all led glows
i think the beeping is related to the overload and/or the low battery
only one 220volt AC LED is connected at inverter output so it can't be overload
Also battery is charged and 6 months old
is the input side connected to the appropriate power source?
if there is an input voltage switch, is it set to the correct supply voltage?
(i blew up an HP ARB, yes, it was HP in those days, not Agilent, by plugging it into a 220V Source, with the switch set to 110V)
Its a fixed Input supply (220Volt)
as noted before, what does the owner's manual say about the beeping and the LEDs?
what does the owners manual say about the first charging, when you take it out of the box to use it?
There is no owner's manual for troubleshootings.

how old is it?
Nearly 8 years old
how old is the battery?
6 months
did you follow all of the steps to set up the UPS?
Yes, I have connected inverter input to 220V and output of inverter is connected to 220V LED bulb (testing)

Sorry for delay in my reply
 

LaTeX Commands Quick-Menu:

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top