Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

LTspice wont start and wont install

cupoftea

Full Member level 6
Joined
Jun 13, 2021
Messages
332
Helped
5
Reputation
10
Reaction score
12
Trophy points
18
Activity points
2,070
Hi,
I just tried to open LTspice, like 100's of times before...but now i just get a dialog box saying "preparing library...", and it just hangs for ages....and wont start.
So i just downloaded LTspice again.....now trying to install it...but an "LTspice installer" dialog box comes up...and its going off the screen bottom, and wont let me move it up.....its asking me to "accept"...but theres obviosuly another button off the bottom of the screen that i cant see...because it wont do anything...how do i resolve this? I cant move this dialog box up....and i cant proceed with the install.
 

Attachments

  • LTspice installer.jpg
    LTspice installer.jpg
    278.8 KB · Views: 54

barry

Advanced Member level 5
Joined
Mar 31, 2005
Messages
5,269
Helped
1,129
Reputation
2,270
Reaction score
1,136
Trophy points
1,393
Location
California, USA
Activity points
28,834
Looks like you need to buy a new computer, Treez.

But seriously: did you uninstall your previous version? Have you restarted your computer?
 

G4BCH

Full Member level 6
Joined
May 10, 2006
Messages
362
Helped
123
Reputation
246
Reaction score
98
Trophy points
1,308
Activity points
4,559
Are you installing on a VM running Windows 11? If so you may need to load guest editions for W11, if it exists to get the screen size right.
 

LaTeX Commands Quick-Menu:

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top