Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Labview communication problem

Status
Not open for further replies.

hadi.parvaz

Newbie level 3
Joined
Jul 21, 2011
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,304
Hello every one

I am using labview data communication functions to make relationship with one of my serial ports to write data to and read data from. I use VISA configure serial port and VISA write function for writing data. Also. I use hyperterminal to monitor port status that is defined virtually. when I run my VI, it doesn't run properly and returns error : "Error -1073807202 occurred at Property Node (arg 1) in VISA Configure Serial Port (Instr).vi->Untitled 1.vi". It is worthy to express that I have done all of adjustments for serial communication port both in hyperterminal and VISA configure serial port function.

I presented my VI and error window in attached file.

I appreciate any help...

tnx
 

Attachments

  • 1.jpg
    1.jpg
    176.2 KB · Views: 49

vinoth8051

Full Member level 3
Joined
Dec 21, 2009
Messages
179
Helped
67
Reputation
134
Reaction score
65
Trophy points
1,328
Location
Delhi, Kanpur, Madurai, India
Activity points
2,380
Hi,
Ensure that visa drivers are installed properly in the system. If not you may download at ftp://ftp.ni.com/support/visa/drivers/ . Have you tried running example serial read write programmes, provided by NI
 

hadi.parvaz

Newbie level 3
Joined
Jul 21, 2011
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,304
Dear S. Vinoth Kumar

Tnx alot for your helpful reply, The file you've introduced is in address NI-VISA 5.0.3 - Pocket PC 2003, Real-Time OS, Windows 7 64 bit/7 x86/Mobile 5/XP Embedded/Server 2008 R2 (64-bit)/Vista x64/Vista x86/XP/Server 2003 R2 (32-bit) - National Instruments named visa503full_downloader.exe (478 MB), Am I right? Is it something that we must install after Labview installation? If yes, I think I haven't installed it yet because I didn't have this driver included in my software package.

Tnx alot for your help
 

vinoth8051

Full Member level 3
Joined
Dec 21, 2009
Messages
179
Helped
67
Reputation
134
Reaction score
65
Trophy points
1,328
Location
Delhi, Kanpur, Madurai, India
Activity points
2,380
Hi hadi.parvaz,
ya you may try this visa driver.VISA drivers are need for serial communications to work. Generally Labview comes in 3 or 4 DVDs. First DVD would be the software base package. Rest of the DVDs are containing drivers for different applications. If you are having driver DVDs you may use that, instead of downloading from NI server.
Hope this helps...
 

hadi.parvaz

Newbie level 3
Joined
Jul 21, 2011
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,304
Dear S. Vinoth Kumar

Again Tnx for your attention

Unfortunately, I don't have the driver packages and all I have is a DVD includes base package. I am going to download it ...

Tnx
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top