Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Intermittent Ethernet Phy Troubleshooting

Orion41414

Newbie
Joined
Jun 25, 2021
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
43
I am currently troubleshooting an Ethernet Phy DP83848IVVX, on a new designed board, the schmatic was reused from one of our old designs which has been working for ages, but its physical size was reduced a fair bit.

The board has a ethernet transformer and non-standard connector for mechanical space reasons unlike the standard RJ45 with built in magnetics of the old design. Unfortunately when I power up the board and connect to the ethernet, the signal is very intermittent, it might run properly for a few minutes then suddenly drop out or cycle on and off rapidly. Thinking it was a magnetics issue i patched in a standard RJ45 with internal magnetics with flying leads. (I know they are high speed signals and it isn't great to do this but I already checked on an old board and it works just fine with no issues)

Even with the proper connector spaced much further out to reduce magnetic interference the problem persists. The one thing I did notice is that if I place my finger on the back of the board under where the transformer used to be the problem can sometimes go away, which leads me to think I need more capacitance, since essentially that is what I am doing with my hand.

Obviously that isn't a practical solution in the long term and I have tried adding capacitors, shielding and grounding around the board to no effect. Does anyone have a suggestion for what could cause it to be so intermittent yet still sometimes work just fine?

I should also mention that I tried looking at the ethernet data with WireShark and the data seems to run fine for a while before getting a "Keep Alive" or a Broadcast frame which seems to be checking to see if the connection is still open. Then the log just fills with random errors after that.

Thanks for any help,
 

LaTeX Commands Quick-Menu:

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top