Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

IBM G74 fitted on philips chassis problem

Status
Not open for further replies.

sawwa7

Full Member level 6
Joined
Oct 30, 2004
Messages
331
Helped
63
Reputation
126
Reaction score
29
Trophy points
1,308
Activity points
2,675
Hi all Colleagues
i have this monitor which was dead with the fron led lighting solid green indicates power supply is ok but black screen .
there was many dry joints on the horizontal output stage and after resolder them i got the no signal displayed but when i go to connect the monitor to pc it shuts down with coloured spot in the middle of the screen .
disconnecting the cable from the vga it gives the No signal message displayed on the screen with normal coloured pattern and solid green power led .
any idea what may cause this?
the monitor is based on philips chassis : CM2617 and service manual is needed for this monitor .
thanks for any help given
Kind Regards
 

sawwa7

Full Member level 6
Joined
Oct 30, 2004
Messages
331
Helped
63
Reputation
126
Reaction score
29
Trophy points
1,308
Activity points
2,675
hi again
well ,just need the pwoer supply and H-scan sections of this monitor or any other equivalent that's close to this chassis if any one can help please .
thanks for any given hand
Kind Regards
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top