Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

hspice no convergence

Status
Not open for further replies.

tofu

Newbie level 5
Joined
Aug 16, 2006
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,358
no convergence in operating point

I'm running transient in hspice and unable to get the circuit to converge.

==================================================
**warning** Due to a floating point overflow problem,
the damped pseudo-tran method was used.
Also, gmindc was set to 1.0000E-11

**diagnostic** time step too small in pseudo tran. delta= 8.8818E-19

no convergence in damped pseudo-transient, trying gmath ramping method


**diagnostic** no convergence in gmath method gmath= 0.00

**diagnostic** begin gshunt ramping
**diagnostic** time step too small in pseudo tran. delta= 5.8208E-19
**diagnostic** time step too small in pseudo tran. delta= 4.2333E-19
**diagnostic** time step too small in pseudo tran. delta= 3.0043E-19
**diagnostic** time step too small in pseudo tran. delta= 2.6234E-19
**diagnostic** time step too small in pseudo tran. delta= 9.8683E-19
**diagnostic** time step too small in pseudo tran. delta= 9.5827E-19
**diagnostic** time step too small in pseudo tran. delta= 9.4461E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3792E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3461E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3296E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3214E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3173E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3153E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3142E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3137E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3135E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3134E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3133E-19

**diagnostic** although this circuit has failed to converge
to gshunt= 0.00 , it did converge to a gshunt= 1.000E-03

**error** no convergence in operating point

***
*** hspice diagnostic ***
nonconvergent voltage failures= 0
nonconvergent element current failures= 0
==================================================

Here's my TRAN section :
==================================================
.TRAN 1.00000E-10 14.00000E-08 START= 0.0000
.TEMP 25.0000
.OP
.save
.OPTION WL post probe opts ACCT
+ PROBE=0
+ DELMAX = 1.00000E-09
==================================================

I tried RELTOL=.01 ALTINT=1 and other options but none of them seem to work.
What else is worth trying?

Any help is appreciated. :D
 

smilelangjun

Member level 1
Joined
Sep 7, 2005
Messages
38
Helped
2
Reputation
4
Reaction score
1
Trophy points
1,288
Activity points
1,456
no convergence in operating point hspice

deleet ACCT and DELMAX
add accurate=1 method=gear
maybe it can pass.
 

ashish_chauhan

Full Member level 5
Joined
Sep 2, 2007
Messages
266
Helped
48
Reputation
96
Reaction score
9
Trophy points
1,298
Activity points
2,674
gshunt ramping failed

try increasing ur run time to some microsecs.
 

tofu

Newbie level 5
Joined
Aug 16, 2006
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,358
no covergence in operating

thanks for the replies but none of the helps. ;\
 

jeffsky520

Member level 4
Joined
Oct 11, 2006
Messages
72
Helped
5
Reputation
10
Reaction score
0
Trophy points
1,286
Activity points
1,586
**error** no convergence in operating point

check your circuit first to be sure correct connections.
 

byteptr

Member level 4
Joined
Apr 29, 2008
Messages
79
Helped
15
Reputation
30
Reaction score
3
Trophy points
1,288
Location
Europe
Activity points
1,781
no convergence in operating point

Is your circuit working with a very short time pulses or expeted very high slew/rates ?
 

northeast1

Full Member level 2
Joined
Jun 21, 2007
Messages
147
Helped
4
Reputation
8
Reaction score
0
Trophy points
1,296
Activity points
1,812
delmax in hspice

tofu said:
I'm running transient in hspice and unable to get the circuit to converge.

==================================================
**warning** Due to a floating point overflow problem,
the damped pseudo-tran method was used.
Also, gmindc was set to 1.0000E-11

**diagnostic** time step too small in pseudo tran. delta= 8.8818E-19

no convergence in damped pseudo-transient, trying gmath ramping method


**diagnostic** no convergence in gmath method gmath= 0.00

**diagnostic** begin gshunt ramping
**diagnostic** time step too small in pseudo tran. delta= 5.8208E-19
**diagnostic** time step too small in pseudo tran. delta= 4.2333E-19
**diagnostic** time step too small in pseudo tran. delta= 3.0043E-19
**diagnostic** time step too small in pseudo tran. delta= 2.6234E-19
**diagnostic** time step too small in pseudo tran. delta= 9.8683E-19
**diagnostic** time step too small in pseudo tran. delta= 9.5827E-19
**diagnostic** time step too small in pseudo tran. delta= 9.4461E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3792E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3461E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3296E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3214E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3173E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3153E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3142E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3137E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3135E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3134E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3133E-19

**diagnostic** although this circuit has failed to converge
to gshunt= 0.00 , it did converge to a gshunt= 1.000E-03

**error** no convergence in operating point

***
*** hspice diagnostic ***
nonconvergent voltage failures= 0
nonconvergent element current failures= 0
==================================================

Here's my TRAN section :
==================================================
.TRAN 1.00000E-10 14.00000E-08 START= 0.0000
.TEMP 25.0000
.OP
.save
.OPTION WL post probe opts ACCT
+ PROBE=0
+ DELMAX = 1.00000E-09
==================================================

I tried RELTOL=.01 ALTINT=1 and other options but none of them seem to work.
What else is worth trying?

Any help is appreciated. :D

change the algrithem.
 

jayanth.neo

Junior Member level 1
Joined
May 20, 2007
Messages
15
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,426
no convergence in operating point +hspice

try using the following .options

I didnt have time to pick out the options. But just use this in ur sim and let me know if u still have probs.

.OP ALL
.OPTION ACCT NODE OPTS LIST LIMTIM=50
+ GMIN=1.00E-12 RELTOL=0.01 ABSTOL=1.00E-12
+ VNTOL=1.00E-06 TRTOL=7.00E+00
+ ITL1=400 ITL2=100 ITL4=100 ITL6=100
+ LVLTIM=2.00E+00 TNOM=+2.50E+01 LIMPTS=99999
+ CHGTOL=1.00E-14
+ MAXORD= .20E+01
+ METHOD=GEAR
+ DELMAX= .00E+00
+ POST
+ CONVERGE=1

Added after 1 minutes:

take out ITL6 = 100, if it is not identified by ur simulator. It depends on the version of hspice u r using.


gud luck
 

Seyab

Newbie level 1
Joined
Feb 6, 2009
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,283
Re: no convergence in operating point

tofu said:
I'm running transient in hspice and unable to get the circuit to converge.

==================================================
**warning** Due to a floating point overflow problem,
the damped pseudo-tran method was used.
Also, gmindc was set to 1.0000E-11

**diagnostic** time step too small in pseudo tran. delta= 8.8818E-19

no convergence in damped pseudo-transient, trying gmath ramping method


**diagnostic** no convergence in gmath method gmath= 0.00

**diagnostic** begin gshunt ramping
**diagnostic** time step too small in pseudo tran. delta= 5.8208E-19
**diagnostic** time step too small in pseudo tran. delta= 4.2333E-19
**diagnostic** time step too small in pseudo tran. delta= 3.0043E-19
**diagnostic** time step too small in pseudo tran. delta= 2.6234E-19
**diagnostic** time step too small in pseudo tran. delta= 9.8683E-19
**diagnostic** time step too small in pseudo tran. delta= 9.5827E-19
**diagnostic** time step too small in pseudo tran. delta= 9.4461E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3792E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3461E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3296E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3214E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3173E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3153E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3142E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3137E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3135E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3134E-19
**diagnostic** time step too small in pseudo tran. delta= 9.3133E-19

**diagnostic** although this circuit has failed to converge
to gshunt= 0.00 , it did converge to a gshunt= 1.000E-03

**error** no convergence in operating point

***
*** hspice diagnostic ***
nonconvergent voltage failures= 0
nonconvergent element current failures= 0
==================================================

Here's my TRAN section :
==================================================
.TRAN 1.00000E-10 14.00000E-08 START= 0.0000
.TEMP 25.0000
.OP
.save
.OPTION WL post probe opts ACCT
+ PROBE=0
+ DELMAX = 1.00000E-09
==================================================

I tried RELTOL=.01 ALTINT=1 and other options but none of them seem to work.
What else is worth trying?

Any help is appreciated. :D
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top