Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

HSIM + Verilog-A + .model

Status
Not open for further replies.

ahmadyan

Newbie level 5
Joined
Mar 20, 2009
Messages
8
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,343
hsim verilog a

Hi, I recently had to port a netlist from hspice to hsim, but encountered some problems regarding .model and verilog-A model in hsim.

the my hspice netlist contains a verilog-a module for mos transistor model. and I had applied tsmc 90n process spec. into him using .model command.
in hspice it seemed fine.

.hdl "model.va"
.model cmosn mos type=1 ...
.model cmosp mos type=-1 ...

X1 1 2 3 4 cmosn ...
X2 5 6 7 8 cmosp ...

however in hsim it doesn't compile this netlist. saying something that it can't find subcirciut or verilog-a module for cmosn or cmosp.

does hsim supports verilog-a module in .model command like hspice?
thanks
 

ahmadyan

Newbie level 5
Joined
Mar 20, 2009
Messages
8
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,343
hsim + verilog-a

any suggestions?
I really need to solve this issue.

tnks
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top