Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

How to use a J-Link clone

Status
Not open for further replies.

Lur711

Newbie level 4
Joined
Dec 4, 2017
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
51
Hi all,

I just bought a J-Link clone and my Segger J-Link software (V6.22) will simply say "Broken. No longer used" regarding my J-Link programmer.

Searching on Google, indeed it's because it's a clone. But I couldn't find any solution to it. I found a lot of "how to unbrick it", but does anyone here knows how do I use this J-Link clone? I just want to upload my firmware to a ATSAM4LC2AA-AU MCU via SWD.

Thanks in advance!
 

andre_teprom

Super Moderator
Staff member
Joined
Nov 7, 2006
Messages
9,299
Helped
1,161
Reputation
2,341
Reaction score
1,151
Trophy points
1,403
Location
Brazil
Activity points
54,161
I would not find it weird at all a clone device being not supported by the original tool/driver, which by the way J-link is Segger copyrighted (notice), and therefore considering that any hint will merely be a patch to make it work, this thread will be closed.
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top