Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

How to run Cadence RCgen without LSF?

Status
Not open for further replies.

TheDock

Newbie level 5
Joined
Mar 6, 2004
Messages
9
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
127
rcgen cadence

Hi everybody,

I'd like to generate an up to date technology file (.tch) with Cadence RCgen contained in the SEV32 packages. I think that the environement variables are configured correctly:

setenv SIMPLEX_HOME $CADENCEDIR/SEV32
setenv PATH "$PATH":$SIMPLEX_HOME/bin
setenv SIMPLEX_VERSION SEV3.2
setenv SIMPLEX_TOOLBOX_H $SIMPLEX_HOME/toolbox
setenv LD_LIBRARY_PATH $SIMPLEX_HOME/tools/lib:${LD_LIBRARY_PATH}

I have renamed the $CAD/SEV32/toolbox/sample_startup_vars to $CAD/SEV32/toolbox/startup_vars

I have modified the $CAD/SEV32/toolbox/sample_startup_vars/lsf_vars file so that "run_lsf_mode = false".
I have modified the $CAD/SEV32/toolbox/sample_startup_vars/wrap_script_vars file so that the LINUX_X86_PEARL, LINUX_X86_HEAD, LINUX_X86_WISH point to the /usr/bin/ directory where the programs are found.

In the working dyrectory (say ~/Foundry/) I have created a file called "hostfile" in which I put the name of the computer I am using. Let's say "iisb-27".

I have then entered the following command at the shell prompt (I am using Linux Red Hat 3.0WS on a Pentium 4 3.0GHz HT CPU):

>RCgen -plan -host hostfile FILE.ict

As explained in the Cadence documentation (Data Preparation Manual in the SEV32 package), this commands creates the scripts for running the model simulations.

The next command to enter for starting the simulations is:

>RCgen -parallel

This command does not work. I get the following error message:
"sh: line 1: parallel: command not found"

When I look in the scripts created after the -plan command, I have a file called "submit_all_jobs.pl" and containing the following text:

` parallel -lsf f hostfile ./one_ended_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./zero_ended_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./xover1_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./xover3_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./corner_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./two_ended_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./two_ended_4lat_models_base.pl `;
`mv parallel_*.log jobs/.`;
` parallel -lsf f hostfile ./two_ended_plate_models_base.pl `;
`mv parallel_*.log jobs/.`;

What I cannot understand is why are there "lsf" options in this file? I though that I had disabled LSF! Is there a procedute to generate the .tch file with RCgen without using this fuc**** LSF stuff? :cry:

Thanks in advance for your answers.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top