Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

help needed with installing IC5033 on Scientific Linux 5.1

Status
Not open for further replies.

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
cadence ic5033 install centos

I have this project to work on ... and I really need this app installed. I tried installing IC5033 on CentOS 5.1 for about a week now ... and still didn't succeed. First there was a problem in choosing the right linux distro ... and as far as I read on this forum ... I understood that Red Hat 8,9 and RHEL 5.0 are most suitable. When I've seen that most of them didn't accept SATA hard-drives I've installed CentOS 5.1 because I've understood that the libraries used for this distro are the same with RHEL.

After that I've tried installing CADENCE ... with IC5033 but I don't know if I'm doing it right. As a tutorial I chose a topic on this forum : . But at the 3rd step of this tutorial when I try to compile the certain file I get lots of warnings. The rest of the configuration goes well until the 7th step ... after choosing all the available packages ... the installation does nothing ... no new appeared in the destination folder.

Could anyone tell me where I've done wrong ? Is there a better tutorial ? Please give me some detailed advice ... noobie style :p I'd prefer.
Thanks in advance.
 

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
cadence lfvhdcomp

Nobody can't help me ? ... I've expecting an answer from you people ... but nothing ?! :(
 

hock

Advanced Member level 2
Joined
May 28, 2001
Messages
525
Helped
47
Reputation
94
Reaction score
21
Trophy points
1,298
Location
India
Activity points
3,567
lf_inst_dir does not appear to

look for my post installing ic5141 on rhel5

hock
 

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
scientific linux assura

thx Hock for the reply ... :)

Is there a difference between installing ic5033 and ic5141 that hock has suggested ?
 

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
scientific linux cadence

hock said:
look for my post installing ic5141 on rhel5

hock


Here's how it went ... after following the steps in Hock's tutorial (all went as planned )... almost at the end of the installation progress I got this error :

Code:
Configuration completed.
Proceeding with configuration of lfvhdComp
LF_INST_DIR (/tmp/cadence/ic5033/tools/leapfrog) does not appear to point at a Leapfrog installation
Please check value and re-install
configuration of lfvhdComp failed


Product Configuration completed.

And I have some questions for which I need some answers:
:?: 1) What is this LeapFrog thing ? What does it do ?

:?: 2) How do I fix this problem in order to finish my installation ?

Thx in advance. :D
 

Riad KACED

Newbie level 6
Joined
Aug 15, 2008
Messages
11
Helped
8
Reputation
16
Reaction score
7
Trophy points
1,283
Location
swindon, UK
Activity points
1,365
configuration of lfvhdcomp

Hi

1. leapFrog is a VHDL simulator
2. In your newly installed IC stream (....../cadence/ic5033/), you should see a directory 'tools.lnx86'. What you need to make the configuration running is to create a 'tools' soft link to your 'tools.lnx86'. You can do this from a unix terminal:
UNIX> cd ....../cadence/ic5033
UNIX> ln -s tools.lnx86 tools

your ic5033 will then have :

tools -> tools.lnx86
tools.lnx86

re-run the configuration and it should run.
BTW, are you installing cadence in the '/tmp' dir ? That's a joke ain't it ?

Cheers,
Riad.

PS:
Do you know the Cadence usenet forum ?
https://groups.google.com/group/comp.cad.cadence/topics
This is the best forum to get your cadence-related questions answered. Some nice and brilliant Application Engineers from the Cadence Customer Support are answering questions in this forum, including the well known gentlemen Andrew Beckett. Please give it a try next time ;-)
 

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
Re: help needed with installing IC5033 on Scientific Linux 5

Riad KACED said:
PS:
Do you know the Cadence usenet forum ?
https://groups.google.com/group/comp.cad.cadence/topics
This is the best forum to get your cadence-related questions answered. Some nice and brilliant Application Engineers from the Cadence Customer Support are answering questions in this forum, including the well known gentlemen Andrew Beckett. Please give it a try next time ;-)

Hi there, Riad
No I didn't know about the group ... lots of interesting stuff around there ... on a simple google search it didn't appear ... if you know some other forums and groups ... please tell me about them ... it's very hard to find some Cadence related sites ... where they discuss ... all kinds of problems ... as I'm at the beginning of learning Cadence I think I would really need them.
 

hock

Advanced Member level 2
Joined
May 28, 2001
Messages
525
Helped
47
Reputation
94
Reaction score
21
Trophy points
1,298
Location
India
Activity points
3,567
Re: help needed with installing IC5033 on Scientific Linux 5

look at this as well.


hock
 

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
Re: help needed with installing IC5033 on Scientific Linux 5

After doing this I managed to install LeapFrog:
Riad KACED said:
You can do this from a unix terminal:
UNIX> cd ....../cadence/ic5033
UNIX> ln -s tools.lnx86 tools

I configured the Bind key by copying all the files from <install_dir>/tools/dfII/sample/local to <install_dir>/tools/dfII/local, and
renamed the cdsinit to .cdsinit.

So far so good.

I edited .bashrc in the /home/user/ folder and it looks like this:
Code:
export CDS_ROOT=/home/bogdan/IC5033/
export CDS_INST_DIR=$CDS_ROOT
export CDS_INSTALL_DIR=$CDS_ROOT/tools/dfII

export CDSDIR=$CDS_ROOT/tools
export CDS_Netlisting_Mode=Analog

export MOZILLA_HOME=/usr/bin/netscape
export XKEYSYMDB=$CDS_ROOT/share/cdssetup/tdmX11/XKeysymDB
export XNLSPATH=$CDS_ROOT/share/cdssetup/tdmX11/nls
export CDS_WAVESCAN_JRE_DIR=$CDS_ROOT/tools/jre1.41

export CDS_LIC_FILE=$CDS_ROOT/share/license/cadence_license_full.dat
export LM_LICENSE_FILE=$CDS_ROOT/share/license/cadence_license_full.dat
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$CDS_ROOT/tools/lib:$CDS_INSTALL_DIR/lib

PATH=$PATH:$CDSDIR/bin:$CDSDIR/dfII/bin:$CDSDIR/SKILL06.00/context:$CDSDIR/SKILL06.10/context:$CDSDIR/dracula/bin
# PATH=$PATH:$MMSIM_ROOT/tools/bin:$MMSIM_ROOT/tools/spectre/bin:$CDS_ROOT/tools/bin:$CDS_ROOT/tools/dfII/bin:/usr/sbin
PATH=$CDS_ROOT/tools/bin:$CDS_INSTALL_DIR/bin:$CDS_ROOT/tools/spectre/bin
PATH=$PATH:$CDS_ROOT/tools/bin:$CDS_INSTALL_DIR/bin:$CDS_ROOT/tools/spectre/bin
PATH=$PATH:/bin:/usr/local/bin:/usr/bin:/usr/ucb:/etc:/usr/openwin/bin:/usr/X11R6/bin
export PATH
#----------------------------------------------------------------------------

# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
	. /etc/bashrc
fi

# User specific aliases and functions

I copied the license.dat to /home/bogdan/IC5033/share/license/cadence_license_full.dat (as the .bashrc file says). Was there anything else to do because after restarting the konsole and when I try to run icfb& it says:

Code:
[1] 4168
[bogdan@localhost ~]$ /home/bogdan/IC5033/tools/dfII/bin/icfb.exe: relocation error: /home/bogdan/IC5033/tools/dfII/bin/icfb.exe: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

[1]+  Exit 127                icfb
 

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
Re: help needed with installing IC5033 on Scientific Linux 5

As I tried to install IC5033 on Scientific Linux 5.1 .... I want to ask if anyone managed to install it on CentOS 4.5 ? Will it work ?


_Squ!D_
 

hock

Advanced Member level 2
Joined
May 28, 2001
Messages
525
Helped
47
Reputation
94
Reaction score
21
Trophy points
1,298
Location
India
Activity points
3,567
Re: help needed with installing IC5033 on Scientific Linux 5

no 5003 supports only kernel 2.4. you can try a tarball installation and LD_Assume_kernel argument.

hock
 

    _SquiD_

    Points: 2
    Helpful Answer Positive Rating

_SquiD_

Advanced Member level 4
Joined
Jul 30, 2008
Messages
114
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
2,035
Re: help needed with installing IC5033 on Scientific Linux 5

Success people !!! Yes hock you were right .... I did try with LD_ASSUME_kernel and it runs ...

Now ... 1) How do I setup a working directory ? Does it need configuring ?
2) How do I import gpdk into my library? (I understood that is already included)
3) LVS , DRC and the other testing methods will work without ASSURA or I need to install it too ?

_Squ!D_
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top