Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

gsm gprs moule problem

Status
Not open for further replies.

Kingjeffrey

Newbie level 2
Joined
Mar 18, 2013
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,295
hello i'm using a sim900D and i'm trying to send a sms through microcontroler
the problem that i was encounter right now is that when i reach the AT+CMGF=1$0D the outcome is error instead of ok..
how can i fixed this please do help me..asap! i'm using a terminal..
 

jay13513

Newbie level 5
Joined
Oct 14, 2008
Messages
8
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,319
For sending sms, the syntax for that is AT+CMGS="xxxxxxxxxxx"<CR><LF> where xxxxxxxxxxx = cell phone number to which you want to send SMS. The hex value for <CR> = 0x0D, and for <LF>=0x0A.
 

Kingjeffrey

Newbie level 2
Joined
Mar 18, 2013
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,295
yahp i know that....
my only problem is AT+CMGF=1$0D I CAN't proceed to other command if i dont fix the error...is their any hex that i can use or if you know the process please do help me or take down the whole program using terminal.,,tnx alot
 

jay13513

Newbie level 5
Joined
Oct 14, 2008
Messages
8
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,319
Okay! But i am not able to get you why you want to use AT+CMGF=1$0D?
 

Debasis Swain

Member level 2
Joined
Feb 2, 2013
Messages
52
Helped
10
Reputation
20
Reaction score
10
Trophy points
1,288
Activity points
1,606
i think you have some problem in code to sent the command from microcontroller. So, try the following code to sent from microcontroller

AT+CMGF=1,0DH,0AH (where 0DH and 0AH both used for special character (enter))
i think this will help you, if it will not solve your problem then sent me your code.

- - - Updated - - -

i think you have some problem in code to sent the command from microcontroller. So, try the following code to sent from microcontroller

AT+CMGF=1,0DH,0AH (where 0DH and 0AH both used for special character (enter))
i think this will help you, if it will not solve your problem then sent me your code.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top