Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] Fuse settings on PIC18F452 and Floating Pin problem

Status
Not open for further replies.

speedEC

Full Member level 6
Joined
Apr 1, 2011
Messages
337
Helped
23
Reputation
46
Reaction score
21
Trophy points
1,298
Activity points
4,326
Hi all,

I am using PIC18F452 to communicate with Hyperterminal thro' PC serial port. Everything works fine. But, I have to touch the (any) wire on the circuit board to work properly. I guess I left some pin on floating. I can't able to identify the pin. The same problem occurred in PIC16F877A. But I found the pin that I left (LVP) and Disable that pin. After that the entire things worked fine. On PIC18F452 same problem but I can't able to find out the floating pin. Is there any other problem? I have attached the fuse settings that I have set. Please go thro' that and pl provide help.

Thanks in advance.

FuseSettings_18F452.gif
 

sunil_n

Member level 1
Joined
Oct 15, 2010
Messages
36
Helped
4
Reputation
8
Reaction score
4
Trophy points
1,288
Location
Bangalore/Coimbatore
Activity points
1,454
hi,

Also check the ground (All GND pins) connections properly.this problem will also occur if you have not given the grounding properly.When you touch, it will get grounded through your body
 

speedEC

Full Member level 6
Joined
Apr 1, 2011
Messages
337
Helped
23
Reputation
46
Reaction score
21
Trophy points
1,298
Activity points
4,326
hi,

Also check the ground (All GND pins) connections properly.this problem will also occur if you have not given the grounding properly.When you touch, it will get grounded through your body
Thanks for the response. I checked my circuit. Everything is OK. I redrew my circuit. Still same problem (I have touch the Wire to work the PIC Correctly). I already disabled the LVP. For more caution, I pull down the LVP Pin to GND thro' 10K.

Any other Idea?
 

speedEC

Full Member level 6
Joined
Apr 1, 2011
Messages
337
Helped
23
Reputation
46
Reaction score
21
Trophy points
1,298
Activity points
4,326
This is my Circuit PIC18F452 - MAX232 - Serial (DB9 male). Any mistake?
circuit_PIC_to_232..jpg
 

speedEC

Full Member level 6
Joined
Apr 1, 2011
Messages
337
Helped
23
Reputation
46
Reaction score
21
Trophy points
1,298
Activity points
4,326
There was a mistake in MCLR Pin connection. Now it is fine.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top