Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Flexlm license problem.

Status
Not open for further replies.

cyc

Member level 1
Joined
May 22, 2001
Messages
38
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
250
debussy license

In case I have more than 2 license files.
Can I just
setenv LM_LICENSE_FILE = license1.dat:license2.dat
and just run lmgrd for once?

I found my two license file would corrupt when the lmgrd is running.

Any answers are appreciated.
 

cyc

Member level 1
Joined
May 22, 2001
Messages
38
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
250
tcp port number debussy 27000

My currently solution is to login as two different users with different LM_LICENSE_FILE setting. Then excute lmgrd in each account.
 

wzdreamer

Full Member level 2
Joined
Jan 16, 2002
Messages
124
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,296
Activity points
1,167
set env lm_license_file point to license.lic

yes cyc,
I do the same...
Or if I'm win Win ME/9X - edit my autoexec.bat and reboot

Some programs requires different variables, and there are no problem...
 

ramesh

Advanced Member level 1
Joined
Jan 19, 2003
Messages
424
Helped
14
Reputation
28
Reaction score
11
Trophy points
1,298
Activity points
2,947
lm_license_file flexlm

Hi cyc

1) Use ";" as delimiter between the file names instead of ":"
2) Use full path for the file.
Ex:- LM_LICENSE_FILE=C:\license1.dat;C:\license2.dat

good luck!
 

roli

Full Member level 5
Joined
Apr 29, 2001
Messages
246
Helped
9
Reputation
20
Reaction score
9
Trophy points
1,298
Location
'SiliconWafer' Island
Activity points
1,824
lmtools merge license

or:
setenv LM_LICENSE_FILE = license1.dat
setenv LM_LICENSE_FILE = {$LM_LICENSE_FILE}:license2.dat
 

petarpav

Full Member level 5
Joined
Mar 25, 2002
Messages
301
Helped
13
Reputation
26
Reaction score
5
Trophy points
1,298
Activity points
2,172
flexlm on same server with different ports

You can join license files into one license file with text editor.

:)
 

dada

Member level 1
Joined
Jun 10, 2002
Messages
37
Helped
4
Reputation
8
Reaction score
4
Trophy points
1,288
Activity points
185
flexlm error -97 121

you can use
setenv LM_LICENSE_FILE license.dat:port@hostname
for lmgrd dameon. this creates no problem
 

padspcb

Member level 4
Joined
Apr 28, 2001
Messages
77
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,288
Location
Earth
Activity points
828
setenv flexlm

Hi
Also you may have different LM_LICENSE_FILE´s depending on user,
because you have one for system variables and other for user.
so you may got server@port;somepath\license.dat;..... for each
and in the end they will sum.
Some old stuff requires the variable on user, others use the system fine.
 

CatKing

Full Member level 3
Joined
Jun 5, 2001
Messages
157
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
1,129
license ncv

for floating licnese, you can point to your port@server one by one, or you can also uses licnese file.

for node-locked license, you can joint all of them into one file. then point to this file.
 

hdang

Member level 1
Joined
Dec 7, 2001
Messages
40
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
337
bug flexlm under windows server 2003

It sounds strange!
Here is a sample of my .cshrc file

setenv CDS_LIC_FILE /usr/local/packages/cadence/license.dat
...

setenv HLD_LICENSE_FILE 3228@?????.???.????.edu
....
setenv MGLS_LICENSE_FILE /usr/local/packages/modeltech/license.lic
...

setenv LM_LICENSE_FILE ${HLD_LICENSE_FILE}:${CDS_LIC_FILE}:${MGLS_LICENSE_FILE}:/usr/local/packages/avant/2000.2/license.lic
...

there is not any problem when running these tools (both nodelock and floating lics) on both Solaris machines and Linux machines. The same applies for my home server with many lmgrd versons.

cyc,
Can you please give us more detail about how it is corrupted then we can help you better.
:oops:
 

hdang

Member level 1
Joined
Dec 7, 2001
Messages
40
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
337
flexlm and lm_license_file

BTW,

lmgrd should run only once on the license server for floating lics does not matter how many clients are working on the entire network. Each user may have different LM_LICENSE_FILE env as long as it point to the correct port@server.
:oops:
 

mars64

Junior Member level 2
Joined
Nov 1, 2001
Messages
20
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
51
set flexlm path

Your may merge this file in single with
dual DAEMON lines, but version lmgrd must be same.

Checkout your license file other use vendor daemon ?
If single merge this files
Checkout yor license file use other port number ?
If same change number port.
LM_LICENSE_FILE --- this string for checking, not for start
 

cyc

Member level 1
Joined
May 22, 2001
Messages
38
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
250
flexlm server delimiter

Hi hdang,

The following is my situlation:

1. When I set LM_LICENSE_FILE = "path of debussy's license file" only. The lmgrd works fine.
2. When I set LM_LISENSE_FILE = "path pf debussy's license file" : "path of ncsim's license file"

When I run lmgrd, I can't start the debussy's license daemon. I saw it is trying different PID. or sometimes reports multiple lisence daemon is started.

Both of the two license files includes server lines and daemon lines.

3. I login as two user account :
debussy: set LM_LICENSE_FILE = debussy's license file.
ncv : set LM_LICENSE_FILE = ncsim's license file.
Then, start the lmgrd at debussy account.

The ncsim doesn't need to run lmgrd.
It works.

Both of my server lines of license file use tcp port 27000. I wonder it is the root cause of this problem. But I haven't tried it.
 

joe2moon

Full Member level 5
Joined
Apr 19, 2002
Messages
280
Helped
19
Reputation
38
Reaction score
7
Trophy points
1,298
Location
MOON
Activity points
3,749
flexlm cas license

Anyone has occurred the following case ?

Before installing one program, all existed tools work fine.
After installing one new software,
it modify the FLEXlm Manager setting automatically, and
the original workable tool can not work anymore :cry:

How to solve this problem ?

Thanks in advance.

ps: All these tools' license(s) as I mentioned are controlled by lmgrd.
 

zoovy

Member level 1
Joined
Dec 15, 2002
Messages
41
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Activity points
558
ncsim license feature lmstat

cyc said:
Hi hdang,

The following is my situlation:

1. When I set LM_LICENSE_FILE = "path of debussy's license file" only. The lmgrd works fine.
2. When I set LM_LISENSE_FILE = "path pf debussy's license file" : "path of ncsim's license file"

When I run lmgrd, I can't start the debussy's license daemon. I saw it is trying different PID. or sometimes reports multiple lisence daemon is started.

Both of the two license files includes server lines and daemon lines.

3. I login as two user account :
debussy: set LM_LICENSE_FILE = debussy's license file.
ncv : set LM_LICENSE_FILE = ncsim's license file.
Then, start the lmgrd at debussy account.

The ncsim doesn't need to run lmgrd.
It works.

Both of my server lines of license file use tcp port 27000. I wonder it is the root cause of this problem. But I haven't tried it.
You are right. The root cause of the problem is both daemons using the same tcp port.
Zoovy
 

hdang

Member level 1
Joined
Dec 7, 2001
Messages
40
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
337
lm_license_file

cyc,

If ncsim does not need to run lmgrd so it does not need the SERVER and DAEMON lines. You can remove them and run if it help (I do not think it is the case though!).

In the case of Debussy. U should do:

+ create the debussy license file with SERVER and DAEMON lines. Let's say debussy.lic (does not need to add this to LM_LICENSE_FILE env)

* run lmgrd -c debussy.lic -l log

+ examine log file to see if all the license feature is valid and the the license daemon for debussy are up (consult Flexlm user guide). Or you can do lmstat -c debussy.lic to see if all features are valid.

** setenv LM_LICENSE_FILE port@yourhostname:eek:ther_license_files

Then run debussy.

Notes that:

:oops: step * only need to run only once.
:wink: ** can be set different for each user but must contain port@yourhostname.

For more information you may read Debussy installation and Flexlm user guide.
:)
 

moorhuhn

Member level 3
Joined
Jul 10, 2002
Messages
54
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
541
how to release debussy license

I would say:
start lmgrd pointing to ONE license file (in case you have 2 license files using the same daemon and the same port,
merge them together)
each license file should use a different port number
after the lmgrd(s) are running you can set
setenv LM_LICENSE_FILE <port_num>@<hostname>:<path_to_lic_file>/license.dat: ....
and all your application sw will find it.

of course different vendors may use different env.vars like
CDS_LIC_FILE or MGLS_LICENSE_FILE ..... so its up to you .
 

eins99

Full Member level 1
Joined
Jan 4, 2003
Messages
98
Helped
2
Reputation
4
Reaction score
0
Trophy points
1,286
Activity points
1,161
flexlm license corrupt

If it is the port addr conflict problem, you can make them different by editing the port addr of your license files. The port adress field is an editable field inside license file. After editing this field the license file is still GOOD. BUT make sure each port address field inside the license file matching with the corresponding port addr you defined in the LM_LICENSE_FILE or whatever environment variables.
 

amarnath

Advanced Member level 1
Joined
Apr 24, 2003
Messages
402
Helped
25
Reputation
50
Reaction score
7
Trophy points
1,298
Activity points
3,141
flexlm tcp port

hello,

u can solve this problem as follows...

lm_license_file=c:\flexlm\license1.dat;c:\flexlm\license2.dat;

any no of paths can be added....to the above...

in win xp there is no problem if this is done..but in win 98...change the properties of autoexec.bat..by setting things like (when u right click on aotoexec.bat then u have options called properties....then change these settings)
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top